Opened 4 years ago

Closed 2 years ago

#123 closed enhancement (wontfix)

Parser just holds on syntax error

Reported by: ssenesi Owned by: ymipsl
Priority: major Component: XIOS
Version: 1.0 Keywords:
Cc:

Description

When reading an xml construct such as

<field field_ref="albs" default_value="1.e+20"/>/>

which shows a syntax error near to the end of line, Xios parser just holds

If the xml file is quite long, you may spend some tens of minutes searching for the error (assuming you suspect it is a syntax error, and you are not beginning your search elsewhere ....)

Change History (2)

comment:1 Changed 3 years ago by rlacroix

I can confirm this issue. It looks like a bug in the XML parser we use, namely RapidXML. Unfortunately development seems to have stalled, there has not been any new versions since 2013.

comment:2 Changed 2 years ago by ymipsl

  • Resolution set to wontfix
  • Status changed from new to closed

The XML file doesn't have the good structure, so the internal XML parser (rapidXML) is lost.
We don't want to modify RapidXML, which is considered as an external tool. At short time we don't plan to replace it with a other (and best) parser.

Note: See TracTickets for help on using tickets.