Opened 8 years ago

Closed 8 years ago

#1046 closed Bug (fixed)

Compilation fails for NEMO v3.4.1 with LIM3

Reported by: barthele Owned by: gm
Priority: highest Milestone:
Component: OCE Version: release-3.4
Severity: Keywords:
Cc:

Description

(problem with NEMO v3.4.1, but this version cannot be chosen in the description of the ticket)

As is, NEMO v3.4.1 cannot be compiled with LIM3. I get the following error :

/home/elic/barthele/modeles/NEMO/NEMOGCM_v3.4.1/CONFIG/ORCA2_LIM3_PAR_29/BLD/ppsrc/nemo/asminc.f90(1041): error #6911: The syntax of this substring is invalid. [HICIF]

zohicif(:,:)=hicif(:,:)

which I think comes from the fact that hicif is just not a model variable in LIM3.

Since I don't need the routine seaice_asm_inc in which the problem is located, my current brute-force solution is to turn it into an empty routine.

Commit History (1)

ChangesetAuthorTimeChangeLog
3784gm2013-02-10T08:27:33+01:00

dev_v3_4_STABLE_2012: #1046 : bug correction to compile LIM3 with ASM

Change History (2)

comment:1 Changed 8 years ago by clevy

  • Owner changed from NEMO team to gm

comment:2 Changed 8 years ago by gm

  • Resolution set to fixed
  • Status changed from new to closed
  • Type changed from Defect to Bug

Thanks Antoine for reporting this bug.

The issue is that the increment applied by ASM (asminc.F90, seaice_asm_inc subroutine) cannot be done in the same way for lim2 and lim3: the 2 ice models do not share the same variable names.

Quick fix: suppress the LIM-3 case in asminc.F90 : see Changeset 3784

A better solution will be to adopt on LIM the same strategy as on CICE, that is asminc.F90 pass the ice increment tendency to the ice model instead of trying to do the work locally.

Gurvan

Note: See TracTickets for help on using tickets.