Opened 8 years ago

Closed 8 years ago

#1064 closed Bug (fixed)

Issues with River code

Reported by: rfurner Owned by: nemo
Priority: low Milestone:
Component: OCE Version: release-3.4
Severity: Keywords:
Cc:

Description

Two bugs have been found in the river code.

Firstly, the filename for rnf_dep_file is not set properly for non-climatological outputs. This is easily fixed, and will be amended in both the trunk and the 2012 merge branch.

Secondly, the way temperature and salinity are dealt with for negative river flows is not conservative.  Where flow is out of the domain, temperature and salinity are set to sea surface values for the grid box in question, however as the flow out can be through depth, this does not give no-change in temperature and salinity as was intended.  To fix this properly 3-d river temperatures and salinities would be needed, which would increase memory costs.  However, the option for outflow to be included as a river has little scientific basis, and is not thought to be used outside of the Met Office, where it will soon be superseded by implementation of true boundary conditions.  As such the memory increase associated with implementing 3-d river temperature and salinity values is not though necessary and instead the option for out flowing river will be removed, with a stop statement added.  this change will be added to both the current trunk and the 2012 merge branch.

Commit History (0)

(No commits)

Change History (1)

comment:1 Changed 8 years ago by rfurner

  • Resolution set to fixed
  • Status changed from new to closed

Changes made to both the trunk and the 2012 merge branch.

Note: See TracTickets for help on using tickets.