Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#1134 closed Bug (invalid)

Large drift & Non-conservation of tracers

Reported by: mouchet Owned by: vichi
Priority: highest Milestone:
Component: TOP Version: release-3.4
Severity: Keywords: conservation
Cc: Anne.Mouchet@…, Olivier.Marti@…

Description

Tests of tracer conservation in NEMO (V3.4 Off line mode, MY_TRC ) failed.
I have no idea of the origin of the problem, whose magnitude highly depends on tracer gradients and fluxes.

I performed the tests with 6 tracers differing by their initial state; further 2 of them undergo exchange at the air-sea interface. In the latter case the gross flux is constrained to be nul.
Nevertheless the drift is significant for all these tracers, but the one initialized with a constant value (tracer 1).

It seems advection is a possible culprit. I tested several schemes, none lead to satisfactory results.

I attach the file containing details on how i proceeded as well as the drift results.

Commit History (0)

(No commits)

Attachments (10)

DRIFT.pdf (70.8 KB) - added by mouchet 7 years ago.
cpp_ORCA2_OFF_MY_TRC.fcm (127 bytes) - added by mouchet 7 years ago.
namelist (70.4 KB) - added by mouchet 7 years ago.
namelist_top (8.4 KB) - added by mouchet 7 years ago.
namelist_watistop (4.5 KB) - added by mouchet 7 years ago.
par_my_trc.F90 (5.3 KB) - added by mouchet 7 years ago.
trcini_my_trc.F90 (4.2 KB) - added by mouchet 7 years ago.
trcnam_my_trc.F90 (3.8 KB) - added by mouchet 7 years ago.
trcsbc.F90 (6.6 KB) - added by mouchet 7 years ago.
trcsms_my_trc.F90 (5.0 KB) - added by mouchet 7 years ago.

Download all attachments as: .zip

Change History (14)

Changed 7 years ago by mouchet

comment:1 follow-up: Changed 7 years ago by vichi

  • Owner changed from NEMO team to vichi
  • Status changed from new to assigned

Hi
can you also attach the namelists you used to run the 50 years run experiment?
And also please specify the configuration you run: ORCA2_LIM or GYRE?
Did you also try to run on-line?

Advection schemes with flux-limiter (MPDATA) are not conservative. Only by using a pure upstream or centred scheme you should achieve conservation. The problem is that when you have a source/sink term, also the positivity of the MPDATA schemes goes wrong and therefore one may have negative concentrations depending on the time step.
If you use a tracer initialized with values closer to 0 (like a nutrient concentration) you should see a larger trend in percentage.
I think we cannot aim to have a conservation that is order the precision of the machine. Gurvan or Christian, any comment on that?

I will redo your tests as well so we can better frame the problem.

comment:2 in reply to: ↑ 1 Changed 7 years ago by mouchet

Bonsoir,

Two days ago I had replied to nemo_st@… with all the information but it seems it got lost.
I'am not used yet to this system.

The configuration i use is: ORCA2_OFF_MY_TRC
You'll find attached to this message all namelists and F90 files i did use for these tests. I also join a copy of the cpp_keys file.

A clarification about the tests: tracer 1 is homogeneous; tracers 2 to 4 have H and V gradients; tracers 5 & 6 have surface (global mean = 0) source/sink terms. All emp (ev/prec/runoff) terms are zero.

Thanks,
Anne

Replying to vichi:

Hi
can you also attach the namelists you used to run the 50 years run experiment?
And also please specify the configuration you run: ORCA2_LIM or GYRE?
Did you also try to run on-line?

Advection schemes with flux-limiter (MPDATA) are not conservative. Only by using a pure upstream or centred scheme you should achieve conservation. The problem is that when you have a source/sink term, also the positivity of the MPDATA schemes goes wrong and therefore one may have negative concentrations depending on the time step.
If you use a tracer initialized with values closer to 0 (like a nutrient concentration) you should see a larger trend in percentage.
I think we cannot aim to have a conservation that is order the precision of the machine. Gurvan or Christian, any comment on that?

I will redo your tests as well so we can better frame the problem.

Changed 7 years ago by mouchet

Changed 7 years ago by mouchet

Changed 7 years ago by mouchet

Changed 7 years ago by mouchet

Changed 7 years ago by mouchet

Changed 7 years ago by mouchet

Changed 7 years ago by mouchet

Changed 7 years ago by mouchet

Changed 7 years ago by mouchet

comment:3 Changed 7 years ago by cetlod

  • Resolution set to invalid
  • Status changed from assigned to closed

In an ocean model, an exact conservation of tracers can only be obtained in non linear feee surface - variable volume of the ocean in response of mass exchange of atmosphere, land and sea-ice - This means that in NEMO it is only achieved if key_vvl is activated and nn_ice_embd = 1 or 2
In linear free surface case the conservation is only approximative with a global error of 10-3 ( see Leclair & Madec 2009, Roullet and Madec 2000) and 10-2 if one doesn't take into account the heat adn salt content associated to moving free surface.
Ib offline mode, the conservation issue is exactly the same

comment:4 Changed 4 years ago by nicolasmartin

  • Cc Anne.Mouchet@… Olivier.Marti@… added; Anne.Mouchet@… removed
  • Keywords conservation added; Drift removed
Note: See TracTickets for help on using tickets.