Opened 7 years ago

Closed 5 years ago

Last modified 4 years ago

#1213 closed Bug (fixed)

XIOS issues

Reported by: rfurner Owned by: nemo
Priority: high Milestone:
Component: OCE Version: release-3.6
Severity: Keywords: XIOS
Cc:

Description

When trying to run the AMM12 with XIOS and the latest merge code (dev_MERGE_2013) I get bizarre failures.

Wihtout key_iomput the model runs fine for 10 days.

With key_iomput things fail. Using the standard iodef.xml file (which I have just recently amended to fit the new XIOS formatting requirements) from the CONFIG/AMM12/EXP00 directory the model should output both daily and every 5 days. It runs until one timestep before the end of the fifth day and gives the following error message;
xios/src/output/onetcdf4.cpp', line 79 → [ status = -60 ] NetCDF: Numeric conversion not representable
Output files are created for both 1d and 5d, but when trying to view them or dump them an error message appears stating that they aren't netcdf format.

Have I 'fixed' the file format incorrectly, or is there something else going on?

Commit History (0)

(No commits)

Change History (3)

comment:1 Changed 7 years ago by rfurner

I think the issue is because level jpk of the tsn array is set as the netcdf missing data value. When outputting from a vvl run, this value is multiplied by fse3t giving a large value which is not the missing data value, and is beyond the limits of what XIOS can output.

It is easily fixed by masking the outputs by tmask before the call to XIOS, however I'm not sure why the bottom lever of tsn is missing data and not zero as the rest of the land masked values, and whether this should be the case.

comment:2 Changed 5 years ago by acc

  • Resolution set to fixed
  • Status changed from new to closed

No such problems encountered with latest trunk (rev5140) and AMM12 SETTE tests (using:

939776000 Feb 26 03:59 ORCA2_LIM_nemo_v3.6.tar

inputs).

comment:3 Changed 4 years ago by nicolasmartin

  • Milestone 2012 Stream 3: New features deleted

Milestone 2012 Stream 3: New features deleted

Note: See TracTickets for help on using tickets.