Opened 12 years ago

Closed 10 years ago

#129 closed Bug (fixed)

Use of F95 signed zero causes incorrect results

Reported by: a.r.porter@… Owned by: nemo
Priority: normal Milestone:
Component: OCE Version: release-2
Severity: Keywords:
Cc:

Description

I have found that compiling NEMO on an IBM system with xlf95 instead of xlf90 creates a binary that produces wrong results (low sea-surface temperatures in the region of Indonesia and 'noise' in these values down the East coast of Africa). I have found the cause of this difference to be the fact that xlf95 supports signed zeros whereas xlf90 does not. (Using -qxlf90=nosignedzero with the xlf95 compiler produces a NEMO binary that behaves correctly.) My understanding is that signed zeros are really only going to affect the result of the SIGN intrinsic but then, there are a lot of those in the NEMO code.

Commit History (0)

(No commits)

Change History (1)

comment:1 Changed 10 years ago by rblod

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in next nemo_v3_3 with a cpp key key_nosignedzero

Note: See TracTickets for help on using tickets.