Opened 6 years ago

Closed 6 years ago

Last modified 3 years ago

#1398 closed Bug (fixed)

LIM3 is not riproducibile

Reported by: flavoni Owned by: nemo
Priority: normal Milestone:
Component: LIM3 Version: release-3.6
Severity: Keywords: LIM*
Cc:

Description

LIM3 run on cluster IBM, proc Intel ES 4650

2 tests : 

jpi=2 jpj= 8, and jpi=4 jpj=4

after 12 timesteps solver.stat are differents.

( options: 

  • -O0 (compiler option)
  • key mpp_rep
  • jperio =  4: cyclic east-west and north fold with T-point pivot)
  • ln_limdyn  = .true.

)

Commit History (1)

ChangesetAuthorTimeChangeLog
4833flavoni2014-11-06T15:58:37+01:00

fix LIM3 reproducibility problems, see ticket #1398

Change History (5)

comment:1 Changed 6 years ago by flavoni

Problem of LIM3 reproducibility was du to this IF in limthd_lac.F90 routine :  

IF( zv_newfra > 0._wp ) THEN

CALL lim_thd_ent( 1, nbpac, ze_i_1d(1:nbpac,:,jl) )

ENDIF

(because different domain decomposition give sometimes zv_newfra >0 and sometimes not.Revision 4833 concerne this bug fix,and I add also initialization, add do from 2 in do loop in IF( fraz_swi == 1 ) and lbc_lnk,and do initialization from 1 to nbpac instead of all jpi*jpj when needed. 

comment:2 Changed 6 years ago by flavoni

  • Resolution set to fixed
  • Status changed from new to closed

comment:3 Changed 3 years ago by nemo

  • Keywords LIM* added

comment:4 Changed 3 years ago by nemo

  • Keywords release-3.6* added

comment:5 Changed 3 years ago by nemo

  • Keywords release-3.6* removed
Note: See TracTickets for help on using tickets.