Opened 5 years ago

Closed 5 years ago

Last modified 3 years ago

#1533 closed Bug (fixed)

XIOS is not correctly initialised when running NEMO in non-MPP

Reported by: hadcv Owned by: hadcv
Priority: low Milestone: 2015 release-3.6
Component: OCE Version: trunk
Severity: Keywords: IOM* NEMO XIOS initialization non-MPP release-3.6
Cc:

Description

XIOS will hang when NEMO is not run with MPP. I had committed a fix for this that apparently did not make it to v3.6 alpha, see #1157.

I propose the same fix as in [1157], including the C1D fix if no-one minds.

Commit History (1)

ChangesetAuthorTimeChangeLog
5412hadcv2015-06-12T20:29:43+02:00
  • Set mpi_comm_opa in non-MPP cases (addresses #1533)
  • Add an xios_context_finalize in step_C1D

Change History (12)

comment:1 Changed 5 years ago by hadcv

I should have also said that this only applies to XIOS in detached / server mode..

comment:2 Changed 5 years ago by hadcv

  • Resolution set to fixed
  • Status changed from new to closed

Done at [5412].

Tests using ORCA2_LIM (previously failing configurations in bold):

  • 2x2 MPP / attached XIOS
  • 2x2 MPP / 1 XIOS server
  • non-MPP / attached XIOS
  • non-MPP / 1 XIOS server

comment:3 Changed 3 years ago by nemo

  • Keywords IOM* added; IOM removed

comment:4 Changed 3 years ago by nemo

  • Keywords NEMO correctly in initialised is non-MPP not running added

comment:5 Changed 3 years ago by nemo

  • Keywords running removed

comment:6 Changed 3 years ago by nemo

  • Keywords is not removed

comment:7 Changed 3 years ago by nemo

  • Keywords initialization added; initialised removed

comment:8 Changed 3 years ago by nemo

  • Keywords in removed

comment:9 Changed 3 years ago by nemo

  • Keywords correctly removed

comment:10 Changed 3 years ago by nemo

  • Keywords release-3.6* added

comment:11 Changed 3 years ago by nemo

  • Keywords release-3.6 added

comment:12 Changed 3 years ago by nemo

  • Keywords release-3.6* removed
Note: See TracTickets for help on using tickets.