Opened 5 years ago

Closed 5 years ago

Last modified 3 years ago

#1587 closed Bug (fixed)

nn_etau=2 bug

Reported by: joakim Owned by: pabouttier
Priority: low Milestone: 2015 release-3.6
Component: OCE Version: release-3.6
Severity: Keywords: TKE
Cc:

Description

I'm trying to run NEMO 3.6 stable with nn_etau=2, to add vertical mixing to the mixed layer base.
However, NEMO always crashes with segmentation fault in the first time step, and I've tracked the issue down to the calculation of mixed layer depth.
The mixed layer depth calculation is called from zdf_tke_init (line 770 in zdftke.f90) if nn_etau = 2.
I think NEMO tries to calculate the mixed layer depth using variables that have not been initialised yet.

Line 770 in zdftke.f90 might therefore need to be either removed or moved somewhere later in the code.

/Joakim

Commit History (1)

ChangesetAuthorTimeChangeLog
6084pabouttier2015-12-17T13:34:28+01:00

Fix segfault in zdf_tke_init, in case of nn_etau = 2 ; See Ticket #1587

Change History (8)

comment:1 Changed 5 years ago by clevy

  • Milestone set to 2015 nemo_v3_6_STABLE
  • Owner changed from NEMO team to pabouttier

comment:2 Changed 5 years ago by bouttier

  • Resolution set to fixed
  • Status changed from new to closed

comment:3 Changed 4 years ago by nicolasmartin

  • Keywords TKE added; zdftke removed

comment:4 Changed 4 years ago by nicolasmartin

  • Keywords etau removed

comment:5 Changed 4 years ago by nicolasmartin

  • Keywords mxl removed

comment:6 Changed 4 years ago by nicolasmartin

  • Keywords nemo_v3_6* added

comment:7 Changed 3 years ago by nemo

  • Keywords release-3.6* added; nemo_v3_6* removed

comment:8 Changed 3 years ago by nemo

  • Keywords release-3.6* removed
Note: See TracTickets for help on using tickets.