Opened 5 years ago

Closed 5 years ago

#1660 closed Enhancement (fixed)

sette_xios.sh now tests the XIOS2.0 interface but changes are required to the supporting scripts to allow automation.

Reported by: acc Owned by: acc
Priority: low Milestone:
Component: OCE Version: release-3.6
Severity: Keywords:
Cc: Review:
MP ready?:
Progress:

Description (last modified by acc)

The nemo_v3_6_stable SETTE/sette_xios.sh script is now intended to test two GYRE configurations using the new XIOS 2.0 library. This involves some syntax changes in the parent XML files (held in CONFIG/GYRE_XIOS) which break some of the SETTE support scripts. The changes ticketed here should allow the sette_xios.sh tests to exist alongside the full sette.sh tests.

The structural and syntax changes that cause issues are:

  1. The splitting of the file descriptions from iodef.xml to an included file: file_def.xml. This causes three problems: a. sette_xios.sh fails to set the output file_type (one_file or multiple_file) because this is no longer in iodef.xml; b. prepare_exe_dir.sh (run by sette_xios.sh) will overwrite iodef.xml with SETTE/iodef_sette.xml but this is now incompatible because it doesn't include file_def.xml. c. file_def.xml is not copied from the reference directory to any new configuration.
  2. Allowing XIOS2 tests to coexist alongside XIOS1 tests means an alternative arch file is needed to link in the correct library. The prepare_job.sh script needs generalisation for the NOC cluster
  3. The syntax changes include reduction of the type of 'using_server' from "boolean" to "bool" (iodef.xml). The set_xio_using_server function needs adapting to try the alternative if the first string is not found.
  4. Finally, an updated sette_rpt.sh script is added which reports on both sette.sh and sette_xios.sh tests.

The solutions fully tested include:

  1. adding a line to TOOLS/COMPILE/Fmake_config.sh so that file_def.xml is copied if it is found in any reference configuration.
  2. Changing prepare_exe_dir.sh so that it doesn't overwrite iodef.xml with iodef_sette.xml if file_def.xml exists in the target directory.
  3. Adapting set_xio_using_server function (all_functions.sh) to look for "bool" if attempts to locate "boolean" fail when searching for the using_server setting in iodef.xml.
  4. Adapting set_xio_file_type function (all_functions.sh) to check for and alter settings in file_def.xml if it is not successful at finding the file_type in iodef.xml

The last point is the least satisfactory since the name file_def.xml is hardwired into the function but this should only be a temporary measure pending the establishment of XIOS2.0.

Changes committed to revision 6224. sette_rpt.sh now reports as follows:

./sette_rpt.sh
WGYRE_LONG            solver.stat restartability  passed :  20160106
WISOMIP_LONG          solver.stat restartability  passed :  20160106
WORCA2LIMPIS_LONG     solver.stat restartability  passed :  20160106
WORCA2LIMPIS_LONG     tracer.stat restartability  passed :  20160106
WORCA2OFFPIS_LONG     tracer.stat restartability  passed :  20160106
WAMM12_LONG           solver.stat restartability  passed :  20160106
WORCA2LIM3_LONG       solver.stat restartability  passed :  20160106
WSAS_LONG             incomplete test
WGYRE_XIOS_LR         checking against  ATTACHED_MULTIPLE
WGYRE_XIOS_LR         solver.stat restartability  passed :  20160107 ATTACHED_ONE
WGYRE_XIOS_LR         solver.stat restartability  passed :  20160107 DETACHED_MULTIPLE
WGYRE_XIOS_LR         solver.stat restartability  passed :  20160107 DETACHED_ONE
WGYRE_XIOS_HR         checking against  ATTACHED_MULTIPLE
WGYRE_XIOS_HR         solver.stat restartability  passed :  20160107 ATTACHED_ONE
WGYRE_XIOS_HR         solver.stat restartability  passed :  20160107 DETACHED_MULTIPLE
WGYRE_XIOS_HR         solver.stat restartability  passed :  20160107 DETACHED_ONE
WGYRE_4               solver.stat reproducibility passed :  20160106
WISOMIP_4             solver.stat reproducibility passed :  20160106
WORCA2LIMPIS_16       solver.stat reproducibility passed :  20160106
WORCA2LIMPIS_16       tracer.stat reproducibility passed :  20160106
WORCA2OFFPIS_16       tracer.stat reproducibility passed :  20160106
WAMM12_32             solver.stat reproducibility passed :  20160106
WORCA2LIM3_16         solver.stat reproducibility passed :  20160106
WSAS_32               incomplete test
WORCA2AGUL_1_2        solver.stat reproducibility passed :  20160106
---------------2nd pass------------------
WSAS_LONG             incomplete test
WSAS_32               incomplete test

Commit History (1)

ChangesetAuthorTimeChangeLog
6224acc2016-01-07T18:02:43+01:00

Branch 2015/nemo_v3_6_STABLE; ticket #1660. Changes required to return full functionality to sette_xios.sh tests which are now targeted at XIOS 2.0 versions. Changes include a new sette_rpt.sh script to summarise sette and sette_xios results even if different arch files are used for the two sets of tests

Change History (1)

comment:1 Changed 5 years ago by acc

  • Description modified (diff)
  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.