Opened 4 years ago

Closed 3 years ago

#1736 closed Bug (fixed)

Correct bugs in UKMO branch dev_r5518_coupling_GSI7_GSI8_landice

Reported by: frrh Owned by: frrh
Priority: low Milestone: Unscheduled
Component: OCE Version: release-3.6
Severity: Keywords:
Cc:

Description (last modified by frrh)

Context

Tim Graham states that use of dev_r5518_coupling_GSI7_GSI8_landice and it's several variants (including the UKMO GO6 package branch) in models which do not feature CICE
causes compilation failures. It should not.

The suspicion is that there are unprotected references to variables emanating from
the CICE code repository in sbccpl.F90.

Analysis

Compiling a Met Office NEMO model with this (and all other) GO6 branches present and with CICE deactivated causes compilation failure in sbccpl.F90.

There appear to be undefined references to A_P, HT_P, KN_ICE and SSTFRZ, all of which appear to be variables defined by CICE code.

There is also a code error in the use of TRIM within a non-CICE block of code controlled by CPP keys.

Additionally there are chunks of code which become unnecessary once CICE is turned off. While these are, in most, but not all, cases protected by run time tests, it is impossible to leave them in the code for compilation since they reference CICE variables directly and will fail compilation.

We aim to correct matters.

Fix

Branch branches/UKMO/dev_r5518_coupling_GSI7_GSI8_landice_bitcomp revision 6651 contains the fix.

Commit History (0)

(No commits)

Change History (5)

comment:1 Changed 4 years ago by frrh

Correcting the TRIM syntax (missing bracket) and inserting suitable #if defined tests on CICE interface related CPP keys in sbccpl.F90 we appear to now have a branch suitable for use regardless of whether CICE is present or not.

I have applied these fixes to
http://fcm3/projects/NEMO.xm/browser/branches/UKMO/dev_r5518_coupling_GSI7_GSI8_landice_bitcomp

since dev_r5518_coupling_GSI7_GSI8_landice contains a reproducibility bug rendering it unsuitable for use in coupled models and should be deleted. I don not know what dev_r5518_coupling_GSI7_GSI8_landice_with_key_asminc is.

The above fix should also be applied to any UKMO GO6 package branch.

comment:2 Changed 4 years ago by frrh

  • Description modified (diff)
  • Owner changed from NEMO team to frrh

comment:3 Changed 4 years ago by frrh

As I understand it, this branch is not intended to go into the NEMO trunk in its entirety, however there are plans to add the functionality associated with the meltponds.

comment:4 Changed 3 years ago by frrh

Closing completed ticket. All relevant codes should now be up to date.

comment:5 Changed 3 years ago by frrh

  • Resolution set to fixed
  • Status changed from new to closed

Closing ticket since not directly destined for NEMO trunk and work has been carried out and documented under MO GMED and/or other MO systems.

Note: See TracTickets for help on using tickets.