Opened 4 years ago

Closed 4 years ago

#1756 closed Bug (fixed)

AttributeError: 'bool' object has no attribute 'author'

Reported by: eolson Owned by: nicolasmartin
Priority: low Milestone: 2016 WP
Component: env Version:
Severity: Keywords: trac
Cc:

Description

Got the following error when trying to diff changesets:
Oops…
Trac detected an internal error:

Attribute Error?: 'bool' object has no attribute 'author'

There was an internal error in Trac. It is recommended that you notify your local Trac administrator with the information needed to reproduce the issue.

To that end, you could

a ticket.

The action that triggered the error was:

GET: /changeset

Trac Guide — The Trac User and Administration Guide

Commit History (0)

(No commits)

Change History (2)

comment:1 Changed 4 years ago by nicolasmartin

  • Component changed from OFF to ENV
  • Keywords trac added
  • Milestone set to 2016 developments
  • Owner changed from NEMO team to nicolasmartin
  • Version nemo_v3_6_STABLE deleted

This is related to a new Trac plugin 'User Pictures', I have temporally disabled it so the changesets diff is back on track.

I'll try to fix it with my little knowledge of the Trac environment, if not I'll will report it to the maintainer of this plugin.

comment:2 Changed 4 years ago by nicolasmartin

  • Resolution set to fixed
  • Status changed from new to closed

Fix has been made by the plugin maintainer, so user pictures are back since few days.

For the members of the ST, I have defined a quite neutral 'Work in progress' image as default in order to induce the customization.
Of course, you are more than encouraging to set your own picture.

Note: See TracTickets for help on using tickets.