Opened 4 years ago

Closed 4 years ago

#1816 closed Bug (wontfix)

No possibility to use the same weight filename with both a 3D and 2D input files to be interpolated ?

Reported by: ctlod Owned by: nemo
Priority: low Milestone:
Component: OCE Version: release-3.6
Severity: Keywords:
Cc:

Description

Context

When using 3D spatial dimension initial temperature/salinity files associated to a 2D weight file for the horizontal interpolation, and
you also would like to use a 2D SSS file extracted from the 3D file one, it seems problematic to use the same 2D weight filename.
This should be confirmed.

Analysis

It seems that when the weight file is associated to a 3D dimension file, the same file can not be associated to a 2D dimension file.
The model is able to read it a first time when reading 3D initial files and stores it in a structure, but when it tries to read it again
and tries to associate it to the SSS input file, the model bugs. The reason is not clear to me since the used FORTRAN structures are different.
The error message arising is that the model find an incoherence between the 3D initial file and 2D SSS file while they are using the same weight filename.

Fix

Use a different filename when using the same weight input file in the ocean namelist.

Commit History (0)

(No commits)

Change History (1)

comment:1 Changed 4 years ago by acc

  • Resolution set to wontfix
  • Status changed from new to closed

This is a 'feature' rather than a true bug. Ideally one should be able to use the same internal structures but those used for 3D and 2D fields are different and an attempt to use the same weights file for 2D and 3D variables will fail.
The association is with the weights filename rather than contents though so the easiest solution is to create symbolic links to the actual files and use the appropriate names in the name list structure. E.g.:

ln -s weights_gridA_bilin.nc weights_gridA_bilin2D.nc
ln -s weights_gridA_bilin.nc weights_gridA_bilin3D.nc
Note: See TracTickets for help on using tickets.