Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#1830 closed Bug (invalid)

Problem with restart from another simulation

Reported by: omamce Owned by: nemo
Priority: normal Milestone:
Component: OCE Version: release-3.6
Severity: Keywords:
Cc: omamce, clevy

Description

Restart problem

Experiences are coupled runs ORCA1_LIM3_PISCES coupled with LMDZ atmosphere model.

  • Experience A : running 10 days in 2 chunks of 5 days.
  • Experience B : same as A, except it starts at day 6, restarting from experience A, end of day 5. At NEMO time step 5 (i.e. after 2 full coupling time steps and 2 calls of ice model and SBC), A and B are different (seen in solver.stat). B starts from nit000=1nn_rstctl=0, coherency between run and restart is not checked.
  • Experience C : same as B, except first iteration of NEMO is set to the same value of the beginning of day 6 in A (i.e. nit000=161). nn_rstctl=2checks that the restart is coherent with the run.

C shows the same results (bit to bit) as A.

  • Experience C' : same as C, but {nn_rstctl=0. Same results than C.

The result of C is fine : bit to bit comparison with A. B should also show this perfect match.

The problem has been tested and observed in 5-daily, montlhy and yearly runs.

Commit History (0)

(No commits)

Change History (2)

comment:1 Changed 4 years ago by clevy

  • Cc omamce clevy added
  • Resolution set to invalid
  • Status changed from new to closed

I've tried to reproduce your problem with the ORCA2_LIM3_PISCES forced reference configuration.
Your difference do not show up: B is identical to A.
The only way to make it different is by making a mistake: in second phase of B (day 5 to 10), since your using nn_rstctl=0, you need to set the appropriate date (=day6) in nn_date0 (your not saying what you did for this variable in your ticket). If you dont, then differences in solver.stat arise.
Moreover, as stated in the comments of namelist_ref:

   nn_rstctl   =       0   !  restart control ==> activated only if ln_rstart=T
                           !    = 0 nn_date0 read in namelist ; nn_it000 : read in namelist
                           !    = 1 nn_date0 read in namelist ; nn_it000 : check consistancy between namelist and restart
                           !    = 2 nn_date0 read in restart  ; nn_it000 : check consistancy between namelist and restart

First thing would be for you to confirm you've indeed changed nn_date0 appropriately in B.
Based on my test, I suggest we consider this problem as related to the configuration, and not to the NEMO reference, so that I'll close this ticket, while leaving your other post on the NEMO in CMIP6 ticket list.

comment:2 Changed 4 years ago by omamce

nn_date0 is correctly set :

Experience A : nn_date0=1950-01-01 for the first pentade, nn_date0=1950-01-06 for the second

Experience B : nn_date0=1950-01-06

Note: See TracTickets for help on using tickets.