Opened 12 years ago

Closed 12 years ago

Last modified 4 years ago

#189 closed Bug (fixed)

trunk: make the CALL sbc_rnf() before the CALL sbc_ssr() since rnfmsk(:,:) array is used in sbcssr.F90, so it must be filled

Reported by: ctlod Owned by: nemo
Priority: low Milestone:
Component: OCE Version: trunk
Severity: Keywords: surface
Cc:

Description


Commit History (1)

ChangesetAuthorTimeChangeLog
1061ctlod2008-06-05T13:03:42+02:00

trunk: make the CALL sbc_rnf() before the CALL sbc_ssr() since rnfmsk(:,:) array is used in sbcssr.F90, so it must be filled, see ticket: #189

Change History (9)

comment:1 follow-up: Changed 12 years ago by ctlod

  • Resolution set to fixed
  • Status changed from new to closed

comment:2 in reply to: ↑ 1 Changed 12 years ago by gm

Replying to ctlod:

It seems to me that there is still a problem when ln_rnf=F and ln_ssr=T. the rnfmsk arrays is never initialised but it is used in sbcssr…

Solutions

sbcmod.F90 =⇒ line 129 change:

	      IF( .NOT. ln_rnf )   nn_runoff = 0      ! no runoff, or runoff mouths

into

	      IF( .NOT. ln_rnf )   THEN
                 nn_runoff   = 0         ! no runoff
                 rnfmsk(:,:) = 0.e0      ! no runoff mouths
              ENDIF

comment:3 Changed 12 years ago by gm

Sorry my comment was not "perfect". I just miss the fact that in traadv_cen2.F90, when ln_rnf=F both rnfmsk and rnfmsk_z are set to zero. so the correct solution for the problem is:

First in sbcmod change line 129

	      IF( .NOT. ln_rnf )   nn_runoff = 0      ! no runoff, or runoff mouths

into

	      IF( .NOT. ln_rnf )   THEN
                 nn_runoff   = 0                                  ! no runoff
                 rnfmsk(:,:) = 0.e0   ;   rnfmsk_z(:) = 0.e0      ! no runoff mouths
              ENDIF

and second in traadv_cen2.F90 suppress the lines 152 to 154, i.e.

         IF( .NOT. ln_rnf ) THEN                         ! no runoff
            rnfmsk(:,:) = 0.e0 ; rnfmsk_z(:) = 0.e0
         ENDIF

comment:4 Changed 4 years ago by nicolasmartin

  • Keywords New Surface module added

comment:5 Changed 4 years ago by nicolasmartin

  • Keywords new added; New removed

comment:6 Changed 4 years ago by nicolasmartin

  • Keywords surface added; Surface removed

comment:7 Changed 4 years ago by nicolasmartin

  • Milestone New Surface Module deleted

Milestone New Surface Module deleted

comment:8 Changed 4 years ago by nicolasmartin

  • Keywords new surface added; NSM removed

comment:9 Changed 4 years ago by nicolasmartin

  • Keywords new removed
Note: See TracTickets for help on using tickets.