Opened 3 years ago

Closed 2 years ago

Last modified 2 years ago

#1924 closed Defect (fixed)

exit value for makenemo

Reported by: rblod Owned by: mchekki
Priority: low Milestone: Unscheduled
Component: env Version: trunk
Severity: Keywords: makenemo
Cc:

Description

Context


When the build fails, makenemo returns an exit code with the value 0 so the compilation success can't be tested (inside a script for instance)

Analysis


The call to fcm always returns 0

Fix


Line 395 add a code number =/ 0 after exit instruction

Commit History (1)

ChangesetAuthorTimeChangeLog
8526timgraham2017-09-15T15:53:50+02:00

Add non-zero exit calls for makenemo errors. See #1924 and #1585

Change History (9)

comment:1 Changed 2 years ago by clevy

  • Owner changed from nemo to mchekki

comment:2 in reply to: ↑ description Changed 2 years ago by hulten

Duplicate of #1585, which contains a (trivial) patch.

There are several exit calls that should have non-zero arguments. I didn't think much about what values.

comment:3 Changed 2 years ago by timgraham

  • Resolution set to fixed
  • Status changed from new to closed

Fixed at r8526

comment:4 Changed 2 years ago by nemo

  • Keywords ENV added

comment:5 Changed 2 years ago by nemo

  • Keywords Misc. added

comment:6 Changed 2 years ago by nemo

  • Keywords ENV removed

comment:7 Changed 2 years ago by nemo

  • Keywords exit for added

comment:8 Changed 2 years ago by nemo

  • Keywords exit for removed

comment:9 Changed 2 years ago by nemo

  • Keywords Misc. removed
Note: See TracTickets for help on using tickets.