Opened 8 months ago

Closed 8 months ago

#2383 closed Bug (invalid)

reproducibility issue with Agrif (likely)

Reported by: clem Owned by: systeam
Priority: low Milestone:
Component: AGRIF Version: release-4.0
Severity: minor Keywords:
Cc:

Description

Analysis

I think there is a reproducibility issue when using Agrif in certain conditions.

In zdftke, the call to Agrif_avm is done before the lbc on avm

#if defined key_agrif 
      ! interpolation parent grid => child grid for avm_k ( ex : at west border: update column 1 and 2)
      IF( l_zdfsh2 )   CALL Agrif_avm
#endif

      !                                         !* Lateral boundary conditions (sign unchanged)
      IF( l_zdfsh2 ) THEN
         CALL lbc_lnk_multi( 'zdfphy', avm_k, 'W', 1. , avt_k, 'W', 1.,   &
            &                          avm  , 'W', 1. , avt  , 'W', 1. , avs , 'W', 1. )
      ELSE
         CALL lbc_lnk_multi( 'zdfphy', avm  , 'W', 1. , avt  , 'W', 1. , avs , 'W', 1. )
      ENDIF

Fix

Reverse lbc and the Agrif call this way:

      !                                         !* Lateral boundary conditions (sign unchanged)
      IF( l_zdfsh2 ) THEN
         CALL lbc_lnk_multi( 'zdfphy', avm_k, 'W', 1. , avt_k, 'W', 1.,   &
            &                          avm  , 'W', 1. , avt  , 'W', 1. , avs , 'W', 1. )
      ELSE
         CALL lbc_lnk_multi( 'zdfphy', avm  , 'W', 1. , avt  , 'W', 1. , avs , 'W', 1. )
      ENDIF

#if defined key_agrif 
      ! interpolation parent grid => child grid for avm_k ( ex : at west border: update column 1 and 2)
      IF( l_zdfsh2 )   CALL Agrif_avm
#endif

But maybe I am missing something here

Commit History (0)

(No commits)

Change History (1)

comment:1 Changed 8 months ago by clem

  • Resolution set to invalid
  • Status changed from new to closed

Invalid since Agrif does not interpolate in the halos

Note: See TracTickets for help on using tickets.