Opened 8 weeks ago

Last modified 7 weeks ago

#2535 reopened Bug

pass sette tests in DEBUG mode...

Reported by: smasson Owned by: systeam
Priority: low Milestone:
Component: MULTIPLE Version: trunk
Severity: minor Keywords:
Cc:

Description

Context

pass sette tests in debug mode and suppress use of undefined values…

Analysis

I finely found the good intel option to initialize allocatable arrays to NaN (for real) and HUGE (for integer) : -init=arrays,snan,huge
-ftrapuv is not working as I expected as it works only with the "stack local variables"… which are not allocatable variables (if I understood correctly)

DEBUG arch files of 2 CNRS machines have been updated and can be use as a model for debugging options with intel: [13529] and [13545]

Fix

good news: undefined values were use only in a few places of the code with harmless consequences.
I corrected them.

Commit History (5)

ChangesetAuthorTimeChangeLog
13583mathiot2020-10-09T14:04:13+02:00

ticket #2535: change for ISOMIP+ to pass sette (for root cause see #2536)

13560smasson2020-10-02T17:42:28+02:00

trun: update sette reference for sette and DEBUG, see #2535

13559smasson2020-10-02T17:36:24+02:00

sette: update sette for DEBUG mode, see #2535

13558smasson2020-10-02T17:30:22+02:00

trunk: pass sette tests with debugging option -init=arrays,snan,huge, see #2535

13546smasson2020-09-30T10:47:59+02:00

trunk: supress the use of undefined values, see #2535

Change History (9)

comment:1 Changed 8 weeks ago by smasson

In 13546:

trunk: supress the use of undefined values, see #2535

comment:2 Changed 8 weeks ago by smasson

  • Resolution set to fixed
  • Status changed from new to closed

this version pass all sette tests with X64_JEANZAY_DEBUG with option -init=arrays,snan. It is not working with -init=arrays,snan,huge

Last edited 8 weeks ago by smasson (previous) (diff)

comment:3 Changed 8 weeks ago by smasson

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:4 Changed 8 weeks ago by smasson

In 13558:

trunk: pass sette tests with debugging option -init=arrays,snan,huge, see #2535

Last edited 8 weeks ago by smasson (previous) (diff)

comment:5 Changed 8 weeks ago by smasson

In 13559:

sette: update sette for DEBUG mode, see #2535

comment:6 Changed 8 weeks ago by smasson

In 13560:

trun: update sette reference for sette and DEBUG, see #2535

comment:7 Changed 8 weeks ago by smasson

since [13560] all tests (except ISOMIP+, see #2536) are now working in debug mode with -init=arrays,snan,huge:

[reee217@jean-zay3: sette]$ ./sette_rpt.sh

Current code is : NEMO/trunk @ r13560  ( last change @ r13560 )

SETTE validation report generated for :

       NEMO/trunk @ r13560 (last changed revision)

       on X64_JEANZAY_DEBUG arch file


!!---------------1st pass------------------!!

   !----restart----!
WGYRE_PISCES_ST              run.stat    restartability  passed :  13560
WGYRE_PISCES_ST              tracer.stat restartability  passed :  13560
WORCA2_ICE_PISCES_ST         run.stat    restartability  passed :  13560
WORCA2_ICE_PISCES_ST         tracer.stat restartability  passed :  13560
WORCA2_OFF_PISCES_ST         tracer.stat restartability  passed :  13560
WAMM12_ST                    run.stat    restartability  passed :  13560
WORCA2_SAS_ICE_ST            run.stat    restartability  passed :  13560
WAGRIF_DEMO_ST               run.stat    restartability  passed :  13560
WWED025_ST                   run.stat    restartability  passed :  13560
WISOMIP+_ST                  ocean.output               MISSING :  13560
WISOMIP+_ST                  incomplete test
WOVERFLOW_ST                 run.stat    restartability  passed :  13560
WLOCK_EXCHANGE_ST            run.stat    restartability  passed :  13560
WVORTEX_ST                   run.stat    restartability  passed :  13560
WICE_AGRIF_ST                run.stat    restartability  passed :  13560

   !----repro----!
WGYRE_PISCES_ST              run.stat    reproducibility passed :  13560
WGYRE_PISCES_ST              tracer.stat reproducibility passed :  13560
WORCA2_ICE_PISCES_ST         run.stat    reproducibility passed :  13560
WORCA2_ICE_PISCES_ST         tracer.stat reproducibility passed :  13560
WORCA2_OFF_PISCES_ST         tracer.stat reproducibility passed :  13560
WAMM12_ST                    run.stat    reproducibility passed :  13560
WORCA2_SAS_ICE_ST            run.stat    reproducibility passed :  13560
WORCA2_ICE_OBS_ST            run.stat    reproducibility passed :  13560
WAGRIF_DEMO_ST               run.stat    reproducibility passed :  13560
WWED025_ST                   run.stat    reproducibility passed :  13560
WISOMIP+_ST                  ocean.output               MISSING :  13560
WISOMIP+_ST                  incomplete test
WVORTEX_ST                   run.stat    reproducibility passed :  13560
WICE_AGRIF_ST                run.stat    reproducibility passed :  13560

   !----agrif check----!
ORCA2 AGRIF vs ORCA2 NOAGRIF run.stat    unchanged  -    passed :  13560 13560

comment:8 Changed 8 weeks ago by smasson

Good news, in debug mode, I get the same run.stat files with or without the option -init=arrays,snan,huge, which suggest that results are now really independent on the way we initialize variables (especially logicals which where a real pain to fix…).
Maybe too nice to be true… Should be double checked…

comment:9 Changed 7 weeks ago by mathiot

In 13583:

ticket #2535: change for ISOMIP+ to pass sette (for root cause see #2536)

Note: See TracTickets for help on using tickets.