Opened 7 weeks ago

Closed 7 weeks ago

#2585 closed Bug (fixed)

Error in formula in Cdn10_Lupkes2012 in sbcblk.F90

Reported by: dlivings Owned by: systeam
Priority: low Milestone:
Component: SBC Version: trunk
Severity: minor Keywords: trunk SBC ice drag SI3
Cc: Branch review: failed
MP ready?: no Task progress: Unspecified

Description

In the current version of NEMO/trunk/src/OCE/SBC/sbcblk.F90 (last changed at [13501]), in subroutine Cdn10_Lupkes2012, there is an error at L1346 in the formula for air-ice drag, or at least an inconsistency with the formula in the comment at L1313 and in the original paper. The exponent (zmu-1._wp) should be just zmu.

Commit History (0)

(No commits)

Change History (2)

comment:1 follow-up: Changed 7 weeks ago by clem

This is not a bug. There is a misunderstanding in the way air-ice drag is used in the code. Wrt Lupkes formulation, we divide the drag by A, hence the factor (mu-1). I describe it in more details hereafter:

The generic air-(ice/ocean) drag described by Lupkes is this one:

Cd = Cdw * (1-A) + Cdi * A + Ce * (1-A)**(nu+1/(10*beta)) * A**mu

Extracting the air-ice drag from it, you find:

Cd_ice * A = Cdi * A + Ce * (1-A)**(nu+1/(10*beta)) * A**mu

The way we use it in the code is without the ice concentration A (because we do not want it to be a cell-average drag). Hence:

Cd_ice = Cdi + Ce * (1-A)**(nu+1/(10*beta)) * A**(mu-1)

comment:2 in reply to: ↑ 1 Changed 7 weeks ago by gsamson

  • Resolution set to fixed
  • Status changed from new to closed

Thanks for explaining it Clément ! I close the ticket

Note: See TracTickets for help on using tickets.