Opened 8 years ago

Closed 8 years ago

#983 closed Bug (fixed)

tide_mod compilation breaks caused by private tide type in ifort

Reported by: momme Owned by: cbricaud
Priority: low Milestone:
Component: OCE Version: trunk
Severity: Keywords:
Cc:

Description

fortcom: Error: /home_nfs/momm/NEMO/3.4-trunk+PMLmods/trunk/NEMOGCM/CONFIG/ORCA1_LIM/BLD/ppsrc/nemo/tide_mod.f90, line 34: This entity cannot be PUBLIC since its derived type is PRIVATE. [WAVE]

Easily fixed by adding
PUBLIC tide
statement.

Commit History (0)

(No commits)

Change History (3)

comment:1 Changed 8 years ago by momme

  • Version changed from nemo_v3_4 to trunk

comment:2 Changed 8 years ago by cbricaud

  • Owner changed from NEMO team to cbricaud

comment:3 Changed 8 years ago by cbricaud

  • Resolution set to fixed
  • Status changed from new to closed

this bug occures when key_tide and key_agrif are activated.

solved at rev 3679
===================================================================
—- tide_mod.F90 (revision 3671)
+++ tide_mod.F90 (working copy)
@@ -20,7 +20,7 @@

INTEGER,PUBLIC, PARAMETER
& jpmax_harmo = 19 ! maximum number of harmonic

TYPE tide

+ TYPE,PUBLIC:: tide

CHARACTER(LEN=4)
cname_tide
REAL(wp)
equitide
INTEGER
nutide
mercator@prod-007:~/NEMO_3.4/trunk/NEMOGCM/NEMO/OPA_SRC/SBC$ svn ci -m "declare TYPE tide as PUBLIC, because of compilation error with key_tide and key_agrif; see ticket 983"
Password:
Sending SBC/tide_mod.F90
Transmitting file data .
Committed revision 3679.

Note: See TracTickets for help on using tickets.