Opened 8 years ago

Closed 8 years ago

#984 closed Bug (duplicate)

bug in lib_mpp/closea due to key_mpp_rep

Reported by: rfurner Owned by: nemo
Priority: low Milestone: Unscheduled
Component: OCE Version: release-3.4
Severity: Keywords:
Cc:

Description

Currently mppsum_realdd (the complex number form for mpp_sum) is only defined in lib_mpp if key_mpp_rep is set. However in closea.F90 lines 230 and 256 use the complex form of mpp_sum, yet are not protected by a pre-compile '# if defined key_mpp_rep' statement, and so the code fails to build without key_mpp_rep.

There are 2 solutions, one is to replace the post compile if statements surrounding lines 210-231 and 247-268 with pre compile ifdefs. The other is to remove the key protection surrounding the definition of mppsum_realdd in lib_mpp.

Rachid feels the second solution is most suitable, there is no real reason to avoid compiling mppsum_realdd.

Commit History (0)

(No commits)

Change History (1)

comment:1 Changed 8 years ago by beppe

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of Ticket #982 (http://forge.ipsl.jussieu.fr/nemo/ticket/982).

Note: See TracTickets for help on using tickets.