Opened 20 months ago

Closed 8 months ago

#730 closed task (fixed)

Adjust spinup, FG1trans and FG2 to work with the new driver

Reported by: luyssaert Owned by: somebody
Priority: minor Milestone: ORCHIDEE 4.1
Component: Driver files Version: trunc
Keywords: Cc:

Description (last modified by luyssaert)

The main configurations should be adjusted to work with the new driver. For this the following tasks need to be done and tested:
(1) Make new default configurations for the spinup_analytic, FG1trans, and FG2 that make use of the new driver.
(2) The following configurations should work with the new driver: SPINUP_ANALYTIC_FG1nd, OOL_SEC_STO_FG1transnd, OOL_SEC_STO_FG2nd, OOL_SEC_STO_FG3nd, OOL_SEC_STO_FG8nd
(3) Also the configurations files of SPINUP_ANALYTIC_FG1nd, OOL_SEC_STO_FG1transnd and OOL_SEC_STO_FG2nd should be tested in a sequence (the default names of the restart files should be adjusted) as well as the starting and end years.
(4) The new driver uses the previous (y-1) as well as the following year (y+1) this makes the useable time series shorter. Adding, for example, 1900 could simplify setups that cycle over 1901 to 1910.

Change History (12)

comment:1 Changed 20 months ago by luyssaert

  • Priority changed from critical to minor

comment:2 Changed 17 months ago by luyssaert

  • Description modified (diff)

comment:3 Changed 16 months ago by luyssaert

  • Resolution set to fixed
  • Status changed from new to closed

(1) Make new default configurations for the spinup_analytic, FG1trans, and FG2 that make use of the new driver.
Committed in r7119
(2) The following configurations should work with the new driver: SPINUP_ANALYTIC_FG1nd, OOL_SEC_STO_FG1transnd, OOL_SEC_STO_FG2nd, OOL_SEC_STO_FG3nd, OOL_SEC_STO_FG8nd
tested prior to commit r7119
(3) Also the configurations files of SPINUP_ANALYTIC_FG1nd, OOL_SEC_STO_FG1transnd and OOL_SEC_STO_FG2nd should be tested in a sequence (the default names of the restart files should be adjusted) as well as the starting and end years.
tested prior to commit r7119
(4) The new driver uses the previous (y-1) as well as the following year (y+1) this makes the useable time series shorter. Adding, for example, 1900 could simplify setups that cycle over 1901 to 1910.
This has been committed in r7112

comment:4 Changed 11 months ago by aducharne

  • Resolution fixed deleted
  • Status changed from closed to reopened

The configs for the new driver include two keywords to controle the timing of precipitation within the forcing time stp: SPREAD_PREC_SEC and SPREAD_PREC_CONT.
Note that the A in SPREAD!
This A is absent in the configs of the trunk (SPRED_PREC_SEC = 3600 in run.def).

comment:5 Changed 11 months ago by aducharne

Some complements about SPRED_PREC, which is not defined similarly by default in the two drivers.

To prevent mistakes, we should change this in the trunk and all working branches. This parameter has a strong influence of the partition of rainfall between surface runoff and infiltration: the smaller SPRED_PREC, the larger surface runoff, and the smaller soil moisture, which can be detrimental for vegetation growth.

1) We should add an A to SPRED_PREC (for nb_spread, the nb of time steps with precip inside one forcing time step), which the only keyword used by both drivers:
Old driver: default valeue = dt_force/2 if dt_force>=3h, else dt_force.
New driver: default value = -1 which calls to use SPREAD_PREC_SEC, the default value of which is 3600s

2) To improve consistency, the default value of SPRED_PREC/nb_spread could be set in the new driver as in the old one.

3) Then, the new driver has additional keywords which overrule SPRED_PREC, i.e. SPREAD_PREC_SEC (default = 3600s) and SPREAD_PREC_CONT (default = n).
=> these keywords should be added with a proper definition in orchidee.default

comment:6 Changed 11 months ago by aducharne

Final comment, to support the addition of an A to SPREAD everywhere: the new driver is not autoconsistent:
!Config Key = SPREAD_PREC_SEC = 3600s
CALL getin_p('SPRED_PREC_SEC', time_to_spread)

!Config Key = SPREAD_PREC_CONT
CALL getin_p('SPREAD_PREC_CONT', spreadprec_cont)

De quoi devenir chèvre!

comment:7 Changed 11 months ago by aducharne

Comment on SPRED_PREC: the default behavior of both drivers (nothing related to SPRED our SPREAD_PREC in the run.def) was checked to be identical with a 6h forcing. But SPEAD_PREC_SEC = 3600 (possible with the new driver) is not the default behaviour, whichever the forcing time step.

Comment on DT_SECHIBA: the two drivers share the same default value of 1800s, but most configurations for the new driver, including all the recent nd configurations of the trunk, set DT_SECHIBA to 1200s in run.def, which increases the run time by 50%. To my opinion, this is not at all useful for meterologogical forcings used with DT_SECHIBA=1800s with the old driver.

Finally, the way to prescribe the simulated domain (zoom) is a bit different in the two drivers:

  • both of them understand LIMIT_WEST, LIMIT_EAST, LIMIT_EAST, LIMIT_NORTH
  • but the new driver adds WEST_EAST and SOUTH_NORTH, in an IF statement I don't really understand, but which seems required for the coupling to WRF.

comment:8 Changed 11 months ago by aducharne

In branch 2_2, r7264 implement the small changes corresponding to comment 5, points 1 and 3. Point 2 is irrelevant, since the default behaviors of the two drivers is the same (comment 7).

comment:9 Changed 10 months ago by xnwang

While running the new driver with the recent trunk rev7290 on Obelix, several things were found and need be modified:

1) in modipsl/util/mod.def, the libIGCM need use the recent version, rev 1548 for example, not 1546.
This can avoid simulation error when running spinup and fg1trans with the new driver.

2) the default forcing file in orchideedriver.card can be changed to the more recent version CRUJRA_v2.2, not v2.1.

3) The existing forcing file in IGCM, that is, CRUJRA_v2.2 for year 1900, should be reprocessed to avoid a simulation error for spinup/fg1tran.
The reprocessing can be realized by using the script AddYears? included in TOOLS/Utilitaire/newdriver. This correction is necessary for both 0.5 and 2deg.

4) Datebegin in config.card of SPINUPALAYTIQUE_nd should be 1901, not 1900

A remark: at the end of several-year simulations, the calling of create_ts/create_se does not work on Obelix, with message in the below.

For example FG2nd:
IGCM_sys_QsubPost : create_se
qsub: cannot send environment with the job
2021-09-20 21:29:52 --------Debug2--> IGCM_sys_QsubPost -o /home/scratch01/xnwang/IGCM_OUT/OL2/TEST/test/FG2.ndV22/Out/create_se.19101231.out -v DEBUG_debug,BigBrother?,postProcessingStopLevel,MODIPSL,libIGCM,libIGCM_SX,SUBMIT_DIR..... /home/surface6/xnwang/orchidee41_7290/modipsl/libIGCM/create_se.job : error code 1
IGCM_debug_Exit : IGCM_sys_QsubPost

This error is also seen when using the previous rev1546 of libIGCM.

comment:10 Changed 9 months ago by jgipsl

1) mod.def updated here for offline configs only : https://forge.ipsl.jussieu.fr/igcmg/changeset/5928

comment:11 Changed 9 months ago by xnwang

Updated the configuration files for SPINUP0nd, SPINUP1nd, FG1transnd and FG2nd. Committed the changes in r7296 of trunk.

comment:12 Changed 8 months ago by luyssaert

  • Resolution set to fixed
  • Status changed from reopened to closed

The old and new driver configuration of similar experiments were compared. Inconsistencies were removed in r7352, r7354 and r7356. All setups, except FG8nd which has not been finalized yet, were tested and confirmed to run. Testing, comparison and subsequent proposition of changes by Xiaoni.

Note: See TracTickets for help on using tickets.