source: tools/trunk/Sophie-tools.spec @ 301

Last change on this file since 301 was 301, checked in by nanardon, 13 years ago
  • being able to create an RPM
File size: 811 bytes
Line 
1%define realname   Sophie-tools
2%define version    0.01
3%define release    %mkrel 1
4
5Name:       Sophie-tools
6Version:    %{version}
7Release:    %{release}
8License:    GPL or Artistic
9Group:      Development/Perl
10Summary:    Sophie Tools
11Source:     %{realname}-%{version}.tar.gz
12Url:        http://sophie.zarb.org/
13BuildRoot:  %{_tmppath}/%{name}-%{version}-%{release}-buildroot
14BuildArch:  noarch
15
16BuildRequires: perl(RPC::XML::Client)
17
18%description
19Tools to query and check rpms using Sophie's website.
20
21%prep
22%setup -q -n %{realname}-%{version} 
23
24%build
25%{__perl} Makefile.PL INSTALLDIRS=vendor
26%make
27
28%check
29make test
30
31%install
32rm -rf %buildroot
33%makeinstall_std
34
35
36%clean
37rm -rf %buildroot
38
39%files
40%defattr(-,root,root)
41%doc Changes README
42%_bindir/*
43%{_mandir}/man1/*
44%{_mandir}/man3/*
45%perl_vendorlib/*
46
Note: See TracBrowser for help on using the repository browser.