Opened 7 years ago

Closed 7 years ago

#56 closed defect (fixed)

XIOS crash sometime in coupled model in server mode

Reported by: ymipsl Owned by: ymipsl
Priority: major Component: XIOS
Version: 1.0 Keywords:
Cc:

Description

When multiple context is used on MPMP code, sometime XIOS crash in server mode.

Change History (2)

comment:1 Changed 7 years ago by ymipsl

  • Status changed from new to assigned

Actually the request from client the server are schedule inside a same context to insure that all server execute the same event to avoid a dead lock when collective mpi communication are performed later in nectdf4/hdf5 libraries.
But no scheduling mechanism exist between different context, so dead lock can appear.

The problem is close to be solve by adding the missing scheduling mechanism between context.

comment:2 Changed 7 years ago by ymipsl

  • Resolution set to fixed
  • Status changed from assigned to closed

Event scheduler has been implemented in rev r492, that will solve the problem.

Note: See TracTickets for help on using tickets.