Opened 6 years ago

Closed 6 years ago

#66 closed defect (fixed)

Regression caused by grid related changes

Reported by: rlacroix Owned by: mhnguyen
Priority: major Component: XIOS
Version: 2.0 Keywords: deadlock, zoom
Cc:

Description

It seems the recent grid related changes have caused a regression which affects the zoom feature. If some processes have nothing to output, XIOS will deadlock. This can be reproduced using the "test_complete" example after r565.

This is possibly caused by the "pseudo-global" communication style used by XIOS, if one client skips the communication with the server, a deadlock will occur.

Change History (1)

comment:1 Changed 6 years ago by mhnguyen

  • Keywords deadlock zoom added
  • Resolution set to fixed
  • Status changed from new to closed

This bug relates to the calculation of real connected servers, which a client needs to send the message to. In some cases of zoom, several server tried to listen to "never come" message, which caused deadlock.
This buf is fixed in r584

Note: See TracTickets for help on using tickets.