Opened 5 years ago

Closed 5 years ago

#85 closed defect (fixed)

Interpolation does not work

Reported by: ssenesi Owned by: ymipsl
Priority: critical Component: XIOS
Version: 2.0 Keywords:
Cc:

Description

Doing a simple test of interpolation to a rectilinear domain fails at the stage of close_context. See attached files : s.xml defines one interpolated field and one single output file. When enabling the interpolated field, XIOS crashes with the attached stack trace.
In my application, almost all definitions are done using the API. The internal grid is an unstructured one.

Attachments (7)

s.xml (908 bytes) - added by ssenesi 5 years ago.
last_run_stderr (5.4 KB) - added by ssenesi 5 years ago.
test_phys.197901.nc (138.5 KB) - added by ssenesi 5 years ago.
xios_server_0.out (36.9 KB) - added by ssenesi 5 years ago.
xios_client_2.out (30.1 KB) - added by ssenesi 5 years ago.
test_phys.197901.2.nc (421.4 KB) - added by ssenesi 5 years ago.
trace (8.2 KB) - added by ssenesi 5 years ago.

Download all attachments as: .zip

Change History (21)

Changed 5 years ago by ssenesi

Changed 5 years ago by ssenesi

comment:1 Changed 5 years ago by ssenesi

revision is 832

comment:2 Changed 5 years ago by ssenesi

The problem occurs both both with gfortran on a PC and with mpifort/mpicc on Meteo-France's Bullx HPC.

Last edited 5 years ago by ssenesi (previous) (diff)

comment:3 Changed 5 years ago by ssenesi

Actually, the internal grid is not unstructured but 'curvilinear', with data_dim=1

comment:4 Changed 5 years ago by ymipsl

Can you send us the src grid mesh. For example you can try to output a single field on the native grid, ie without making any interpolation.
Did you check your memory consumption ?

comment:5 Changed 5 years ago by ssenesi

The field before interpolation is attached
Regarding memory footprint, I do not think this is basic at the stage of closing_context. I attach the server.out file

Changed 5 years ago by ssenesi

Changed 5 years ago by ssenesi

Changed 5 years ago by ssenesi

comment:6 Changed 5 years ago by ymipsl

Where are your cell bounds ? Nothing is defined in the file.

comment:7 Changed 5 years ago by ssenesi

Oups ! Good remark : for the case on curvilinear grid, I just delayed providing the bounds, and forgot about it when complaining about interpolation. Sorry about that and thanks for the support !

May be XIOS could tell more softly what the problem is in such a case ?

Thanks again.

comment:8 Changed 5 years ago by ymipsl

In fact, we are not so clean too. We will solve this problem to get an clear message when bounds are missing in order to avoid again such mistake.

Regards,

comment:9 Changed 5 years ago by ssenesi

OK. I know was able to provide cell bounds (see attached file). The run exits with a single message :

Error: neighbour not found

Is it due to the fact that the target domain largely exceeds the extent of the source domain ?

Changed 5 years ago by ssenesi

comment:10 Changed 5 years ago by ssenesi

The 'neighbour not found' error (above) occurs when task number is 1.
When task number is 2, I got the attached stack trace (file 'trace')

Changed 5 years ago by ssenesi

comment:11 Changed 5 years ago by ssenesi

The problem disappeared using version 855

comment:12 Changed 5 years ago by rlacroix

@Stéphane: As far as I understand this ticket can be closed as fixed?

comment:13 follow-up: Changed 5 years ago by ssenesi

Yes, that's what I meant by

"The problem disappeared using version 855"

Am I empowered to close a ticket ?

comment:14 in reply to: ↑ 13 Changed 5 years ago by rlacroix

  • Resolution set to fixed
  • Status changed from new to closed

Replying to ssenesi:

Am I empowered to close a ticket ?

Probably not but no problem, I will do it.

Note: See TracTickets for help on using tickets.