New URL for NEMO forge!   http://forge.nemo-ocean.eu

Since March 2022 along with NEMO 4.2 release, the code development moved to a self-hosted GitLab.
This present forge is now archived and remained online for history.
#1245 (Memory leak during tangent-linear and adjoint time steps) – NEMO

Opened 9 years ago

Closed 9 years ago

Last modified 10 months ago

#1245 closed Bug (fixed)

Memory leak during tangent-linear and adjoint time steps

Reported by: sam Owned by: pabouttier
Priority: normal Milestone:
Component: TAM Version: v3.4
Severity: Keywords: TAM v3.4
Cc:

Description

Memory leaks are caused by the code in NEMOGCM/NEMO/OPATAM_SRC/TRA/traldf_iso_tam.F90. Subroutine 'tra_ldf_iso_tan' lacks the deallocation of the work arrays 'zftutl' and 'zftvtl', and subroutine 'tra_ldf_iso_adj' lacks the deallocation of the work arrays 'zdjsad' and 'zdisad'.

Commit History (1)

ChangesetAuthorTimeChangeLog
4530pabouttier2014-03-17T11:00:08+01:00

Fix memory leak in traldf_iso_tam.F90, see Ticket #1245

Change History (7)

comment:1 Changed 9 years ago by clevy

  • Owner changed from NEMO team to pabouttier

comment:2 Changed 9 years ago by pabouttier

  • Resolution set to fixed
  • Status changed from new to closed

comment:3 Changed 6 years ago by nicolasmartin

  • Keywords TAM added

comment:4 Changed 6 years ago by nicolasmartin

  • Keywords nemo_v3_4* added

comment:5 Changed 5 years ago by nemo

  • Keywords release-3.4* added; nemo_v3_4* removed

comment:6 Changed 5 years ago by nemo

  • Keywords release-3.4* removed

comment:7 Changed 10 months ago by nemo

  • Keywords v3.4 added
Note: See TracTickets for help on using tickets.