Opened 6 years ago

Closed 5 years ago

Last modified 4 years ago

#1630 closed Bug (fixed)

Strange sea-ice albedo for ice with little melting snow on top

Reported by: ufla Owned by: vancop
Priority: low Milestone:
Component: LIM3 Version: release-3.6
Severity: Keywords: LIM*
Cc: Branch review:
MP ready?: Task progress:

Description

Forwarding this on behalf of my colleague Klaus Wyser who deserves the credits:

Sea-ice albedo is computed in NEMO/OPA_SRC/SBC/albedo.F90 taking into account snow on top of the sea-ice. The equations are:

!  Case of ice covered by snow.             
!                                        !  freezing snow        
zihsc1   = 1.0 - MAX( zzero , SIGN( zone , - ( ph_snw(ji,jj,jl) - c1 ) ) )
zalbpsnf = ( 1.0 - zihsc1 ) * (  zficeth(ji,jj,jl)                                             &
   &                          +  ph_snw(ji,jj,jl) * ( rn_alphd - zficeth(ji,jj,jl) ) / c1  )   &
   &     +         zihsc1   * rn_alphd
!                                        !  melting snow                
zihsc2   = MAX( zzero , SIGN( zone , ph_snw(ji,jj,jl) - c2 ) )
zalbpsnm = ( 1.0 - zihsc2 ) * ( rn_albice + ph_snw(ji,jj,jl) * ( rn_alphc - rn_albice ) / c2 ) &
         &     +         zihsc2   *   rn_alphc

where zficeth is the sea-ice albedo (with no snow on top) as a function of the sea-ice thickness, zalbpsnf and zalbpsnm are the albedos for the snow and sea-ice complex under freezing or melting conditions. When the snow gets thin (ph_snw —> 0), the values of zalbpsnf and zalbpsnm approach zficeth and rn_albice, respectively.

The issue is in the computation of zalbpsnm. rn_albice is the asymptotic albedo value for thick melting ice and constant, while zficeth is a function of the sea-ice thickness. When the ice gets thin enough, zficeth<rn_albice which leads to the strange situation that the albedo of ice with little freezing snow on top is lower than the albedo of ice with a little melting snow layer on top. An alternative formulation would be:

zalbpsnm = ( 1.0 - zihsc2 ) * ( zficeth(ji,jj,jl) + ph_snw(ji,jj,jl) * ( rn_alphc - zficeth(ji,jj,jl) ) / c2 )   &
   &     +         zihsc2   *   rn_alphc

Admittedly this will not make a big difference in the results, yet a bug is a bug…

Commit History (0)

(No commits)

Change History (6)

comment:1 Changed 5 years ago by vancop

  • Owner changed from NEMO team to vancop

comment:2 Changed 5 years ago by vancop

We agree with your finding that the melting snow albedo can be higher than the freezing.
This is obviously wrong, but intrinsic to the parameterization of Shine
& Henderson-Sellers, not to the implementation made in LIM.

Your patch correctly addresses the issue you mention, but deteriorates
snow albedo at higher ice thickness and snow depth, however.

So we chose to keep the parameterization as is and accept its flaws for
the moment.

We (Clément) are rewriting a more consistent albedo parameterization, in the
lines of Shine & Henderson-Sellers, but with improved functional
dependencies as a function of snow depth and ice thickness, on the base
of published recent measurements. This will take some time before we are
happy with it. Our plan at IPSL is to plug it in as a patch for CMIP6.
We'd definitely share that with you and tell you when it is ready.

Martin & Clément

comment:3 Changed 5 years ago by clem

  • Resolution set to fixed
  • Status changed from new to closed

comment:4 Changed 4 years ago by nemo

  • Keywords LIM* added

comment:5 Changed 4 years ago by nemo

  • Keywords release-3.6* added

comment:6 Changed 4 years ago by nemo

  • Keywords release-3.6* removed
Note: See TracTickets for help on using tickets.