New URL for NEMO forge!   http://forge.nemo-ocean.eu

Since March 2022 along with NEMO 4.2 release, the code development moved to a self-hosted GitLab.
This present forge is now archived and remained online for history.
#1799 (NEMO 3.6_STABLE : lib_mpp compilation error with intel 17 and openmpi) – NEMO

Opened 7 years ago

Closed 6 years ago

#1799 closed Bug (fixed)

NEMO 3.6_STABLE : lib_mpp compilation error with intel 17 and openmpi

Reported by: molines Owned by: mchekki
Priority: highest Milestone:
Component: OCE Version: v3.6
Severity: Keywords:
Cc:

Description

Context

  • Compiling NEMO_3.6_STABLE on brand new machine occigen2 (with intel 17 and openmpi/intel/2.0.1 ) there are catastrophic errors for the compilation of lib_mpp.F90.
  • It compiles OK for the trunk revision
  • The reported error (repeated many times) is :
    /opt/mpi/openmpi-icc/2.0.1/include/mpif-sizeof.h(17): error #5286: Ambiguous generic interface MPI_SIZEOF: previously declared specific procedure MPI_SIZEOF_COMPLEX128_SCALAR is not distinguishable from this declaration. [MPI_SIZEOF_COMPLEX128_SCALAR]
          SUBROUTINE MPI_Sizeof_complex128_scalar(x, size, ierror)
    ...
    /tmp/ifortqJ6iPG.i90(13215): catastrophic error: Too many errors, exiting
    
    

Analysis

  • In lib_mpp.F90 (v3.6_STABLE) the statement
       INCLUDE 'mpif.h'
    
    is repeated 3 times ( At the begining of the module and in 2 subroutines)
  • This is the cause of the error. Note that with previous version of the compiler and/or openmpi, it was not a problem

Fix

  • remove uncesseary statements in the routines, and only keep the one at the beginning of the module

Commit History (1)

ChangesetAuthorTimeChangeLog
8537gm2017-09-19T07:46:09+02:00

#1799 : correct a compilation error in lib_mpp with intel 17 and openmpi

Change History (4)

comment:1 Changed 7 years ago by molines

  • Priority changed from minor to blocker

comment:2 Changed 7 years ago by molines

  • Just to remember that this is not fixed yet in last revision of 3.6_STABLE, so that compilation of the code fails on occigen.

comment:3 Changed 7 years ago by clevy

  • Owner changed from nemo to mchekki

comment:4 Changed 6 years ago by gm

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.