New URL for NEMO forge!   http://forge.nemo-ocean.eu

Since March 2022 along with NEMO 4.2 release, the code development moved to a self-hosted GitLab.
This present forge is now archived and remained online for history.
#2106 (Floating invalid in limthd_dh.f90) – NEMO

Opened 4 years ago

Closed 3 years ago

Last modified 3 months ago

#2106 closed Bug (wontfix)

Floating invalid in limthd_dh.f90

Reported by: tian Owned by: vancop
Priority: low Milestone:
Component: LIM3 Version: v3.6
Severity: major Keywords: LIM v3.6
Cc: uwe.fladrich@…

Description

The problem is that I get a error of floating invalid in limthd_dh.f90, line 460 & line 487. It happens in the coupled configuration (ifs_grid=T255L91, nem_grid=OR
CA1L75) when I apply a sea ice restart file, remapped from ORCA025L75 to ORCA1L71. The coupled model crashes in the first time-step.

I detect some grid points having zero in the denominator of a fraction " ( ztmelts - rt0 ) / ( zt_i_new - rt0 ) ", where ztmelts, rt0 and zt_i_new all equal to 273.15. It is because regridding introduces zero-value to those grid points. I solve it by adding epsi20 to the denominator. As the numerator of the fraction is also zero, the fraction will be zero with the new denominator ( zt_i_new - rt0 + epsi20).

Commit History (1)

ChangesetAuthorTimeChangeLog
9883clem2018-07-05T17:57:31+02:00

solve issue raised in ticket #2107 and maybe in ticket #2106

Change History (6)

comment:1 Changed 4 years ago by clevy

  • Owner set to vancop
  • Status changed from new to assigned

comment:2 Changed 4 years ago by clem

When zt_i_new = 273.15 it usually means that the sea surface salinity = 0 at this point.
Therefore I would suggest to check the surface salinity first.

comment:3 Changed 4 years ago by clem

In 9883:

Error: Failed to load processor CommitTicketReference
No macro or processor named 'CommitTicketReference' found

comment:4 Changed 4 years ago by clem

I changed a couple of things in the ice code that could produce this error. If you take r9883, you should not need the epsi20 trick you used, and the solution should be cleaner.

comment:5 Changed 3 years ago by vancop

  • Resolution set to wontfix
  • Status changed from assigned to closed

obsolete for nemo v4

comment:6 Changed 3 months ago by nemo

  • Keywords v3.6 added
Note: See TracTickets for help on using tickets.