New URL for NEMO forge!   http://forge.nemo-ocean.eu

Since March 2022 along with NEMO 4.2 release, the code development moved to a self-hosted GitLab.
This present forge is now archived and remained online for history.
#2294 (Missing rewind on reference namelist for nambdy_tides) – NEMO

Opened 3 years ago

Closed 3 years ago

Last modified 8 months ago

#2294 closed Defect (fixed)

Missing rewind on reference namelist for nambdy_tides

Reported by: mdunphy Owned by: systeam
Priority: low Milestone:
Component: BDY Version: v4.0
Severity: minor Keywords: namelists v4.0
Cc:

Description

Context

When we have >1 open boundary, and when using ln_tide=.true., we get this warning:

W A R N I N G: end of record or file while reading namelist nambdy_tide in reference namelist iostat = -1

Analysis

nambdy_tide appears nb_bdy times in the config namelist, but only once in the reference namelist. So we may not initialize the members of nambdy_tides with the reference values for the second and onwards open boundary

Recommendation

We should rewind the reference namelist before each read of nambdy_tide, as done in bdydta.F90 for nambdy_dta. Patch attached

Commit History (0)

(No commits)

Attachments (1)

nambdy_tides.patch (898 bytes) - added by mdunphy 3 years ago.
Add rewind to reference namelist read in bdytides.F90

Download all attachments as: .zip

Change History (5)

Changed 3 years ago by mdunphy

Add rewind to reference namelist read in bdytides.F90

comment:1 Changed 3 years ago by mdunphy

The issue is present in NEMO 3.6 as well

comment:2 Changed 3 years ago by smasson

Done in branches/2019/dev_r10984_HPC-13_IRRMANN_BDY_optimization, see [11223]
Do we need to report this bugfix in v4.0, knowing that v4.0.1 will be released soon?

comment:3 Changed 3 years ago by smasson

  • Resolution set to fixed
  • Status changed from new to closed

comment:4 Changed 8 months ago by nemo

  • Keywords v4.0 added
Note: See TracTickets for help on using tickets.