Opened 7 months ago

Closed 6 months ago

#2440 closed Bug (fixed)

Issue with land processors removal

Reported by: jchanut Owned by: systeam
Priority: high Milestone:
Component: AGRIF Version: 4.0-HEAD
Severity: major Keywords:
Cc:

Description

Context

The rewriting of mpp initialization has theoretically allowed some flexibility in defining different mpp layouts over each AGRIF grid. This includes the removal of land processors over parent and child grids.

Analysis

Boundary conditions in an AGRIF zoom are set by detecting if the processor domain includes the global domain edges. This is done by using nbondi/nbondj integers that define the type of east/west/north/south neighbors. Doing so potentially marks a local domain close to a land processor domain as a "boundary domain". Hence, AGRIF will attempt to set boundary conditions in that case. In some circonstances, this updates ocean points that should't be updated.

Fix

The use of nbondi/nbondj has been suppressed in the last version (trunk), the reasoning being done on global indexes. In earlier NEMO 4.0 versions, we should define once for all (in mppini) logicals to detect if a local domain lays on one of global domain edges.


Commit History (1)

ChangesetAuthorTimeChangeLog
12857jchanut2020-05-02T18:06:55+02:00

Correct swapped conditionnal statement in corners (hence undetected without corners) introduced in previous commit, #2440

Change History (4)

comment:1 Changed 6 months ago by jchanut

  • Resolution set to fixed
  • Status changed from new to closed

Successfully tested mpp reproducibility in an ARCTIC zoom with lots of land subdomains.

comment:2 Changed 6 months ago by jchanut

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:3 Changed 6 months ago by jchanut

In 12857:

Correct swapped conditionnal statement in corners (hence undetected without corners) introduced in previous commit, #2440

comment:4 Changed 6 months ago by jchanut

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.