New URL for NEMO forge!   http://forge.nemo-ocean.eu

Since March 2022 along with NEMO 4.2 release, the code development moved to a self-hosted GitLab.
This present forge is now archived and remained online for history.
#2529 (Incorrect length for IOM "ptr" zoom domain) – NEMO

Opened 2 years ago

Closed 2 years ago

#2529 closed Bug (fixed)

Incorrect length for IOM "ptr" zoom domain

Reported by: hadcv Owned by: ayoung
Priority: low Milestone: Unscheduled
Component: IOM Version: trunk
Severity: critical Keywords: diaptr, set_grid_znl
Cc:

Description (last modified by ayoung)

When using the "ptr" domain for diaptr output, only the first jpj rows are output. Upgraded from minor to critical as this causes the job failure in sette tests.

Fix

Replace the nj argument in iom.F90:

- CALL iom_set_zoom_domain_attr("ptr", ibegin=ix-1, jbegin=0, ni=1, nj=Nj_0)
+ CALL iom_set_zoom_domain_attr("ptr", ibegin=ix-1, jbegin=0, ni=1, nj=Nj0glo)

Commit History (3)

ChangesetAuthorTimeChangeLog
13716ayoung2020-11-02T18:32:26+01:00

Changed ptr bounds from local to global. See ticket #2529

13713ayoung2020-11-02T13:51:03+01:00

Changed ptr bounds from local to global. See ticket #2529.

13711ayoung2020-11-02T12:34:21+01:00

Branch to implement ptr bug fix. See ticket #2529.

Change History (10)

comment:1 Changed 2 years ago by hadcv

  • Type changed from Defect to Bug

comment:2 Changed 2 years ago by hadcv

  • Description modified (diff)
  • Keywords set_grid_znl added

comment:3 Changed 2 years ago by hadcv

  • Description modified (diff)

comment:4 Changed 2 years ago by ayoung

  • Description modified (diff)
  • Owner changed from hadcv to ayoung
  • Severity changed from minor to critical
  • Status changed from new to assigned

comment:5 Changed 2 years ago by ayoung

In 13711:

Error: Failed to load processor CommitTicketReference
No macro or processor named 'CommitTicketReference' found

comment:6 Changed 2 years ago by ayoung

In 13713:

Error: Failed to load processor CommitTicketReference
No macro or processor named 'CommitTicketReference' found

comment:7 Changed 2 years ago by ayoung

Code now passes sette tests. Note the "change in results" between 13713 and 13711 is simply because it was failing to run at revision 13711, and now runs sucessfully.

Current code is : NEMO/branches/2020/ticket2529 @ r13713 ( last change @ r13713 )

SETTE validation report generated for :

NEMO/branches/2020/ticket2529 @ r13713 (last changed revision)

on XC40_METO_IFORT arch file

!!---------------1st pass------------------!!

!----restart----!

WGYRE_PISCES_ST run.stat restartability passed : 13713
WGYRE_PISCES_ST tracer.stat restartability passed : 13713
WORCA2_ICE_PISCES_ST run.stat restartability passed : 13713
WORCA2_ICE_PISCES_ST tracer.stat restartability passed : 13713
WORCA2_OFF_PISCES_ST tracer.stat restartability passed : 13713
WAMM12_ST run.stat restartability passed : 13713
WORCA2_SAS_ICE_ST run.stat restartability passed : 13713
WAGRIF_DEMO_ST run.stat restartability passed : 13713
WWED025_ST run.stat restartability passed : 13713
WISOMIP+_ST run.stat restartability passed : 13713
WOVERFLOW_ST run.stat restartability passed : 13713
WLOCK_EXCHANGE_ST run.stat restartability passed : 13713
WVORTEX_ST run.stat restartability passed : 13713
WICE_AGRIF_ST run.stat restartability passed : 13713

!----repro----!

WGYRE_PISCES_ST run.stat reproducibility passed : 13713
WGYRE_PISCES_ST tracer.stat reproducibility passed : 13713
WORCA2_ICE_PISCES_ST run.stat reproducibility passed : 13713
WORCA2_ICE_PISCES_ST tracer.stat reproducibility passed : 13713
WORCA2_OFF_PISCES_ST tracer.stat reproducibility passed : 13713
WAMM12_ST run.stat reproducibility passed : 13713
WORCA2_SAS_ICE_ST run.stat reproducibility passed : 13713
WORCA2_ICE_OBS_ST run.stat reproducibility passed : 13713
WAGRIF_DEMO_ST run.stat reproducibility passed : 13713
WWED025_ST run.stat reproducibility passed : 13713
WISOMIP+_ST run.stat reproducibility passed : 13713
WVORTEX_ST run.stat reproducibility passed : 13713
WICE_AGRIF_ST run.stat reproducibility passed : 13713

!----agrif check----!

ORCA2 AGRIF vs ORCA2 NOAGRIF run.stat unchanged - passed : 13713 13713

!----result comparison check----!

check result differences between :
VALID directory : /home/d00/ayoung/NEMO_Tickets/ticket2529/NEMO_VALIDATION at rev 13713
and
REFERENCE directory : /home/d00/ayoung/NEMO_Tickets/ticket2529/NEMO_VALIDATION at rev 13711

WGYRE_PISCES_ST run.stat files are identical
WGYRE_PISCES_ST tracer.stat files are identical
WORCA2_ICE_PISCES_ST incomplete test
WORCA2_OFF_PISCES_ST tracer.stat files are identical
WAMM12_ST run.stat files are identical
WORCA2_SAS_ICE_ST run.stat files are identical
WAGRIF_DEMO_ST run.stat files are identical
WWED025_ST run.stat files are identical
WISOMIP+_ST run.stat files are identical
WVORTEX_ST run.stat files are identical
WICE_AGRIF_ST run.stat files are identical
WOVERFLOW_ST run.stat files are identical
WLOCK_EXCHANGE_ST run.stat files are identical

comment:8 Changed 2 years ago by smasson

I agree with the proposed bugfix ;-)

comment:9 Changed 2 years ago by ayoung

In 13716:

Error: Failed to load processor CommitTicketReference
No macro or processor named 'CommitTicketReference' found

comment:10 Changed 2 years ago by ayoung

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.