New URL for NEMO forge!   http://forge.nemo-ocean.eu

Since March 2022 along with NEMO 4.2 release, the code development moved to a self-hosted GitLab.
This present forge is now archived and remained online for history.
#2631 (Use XIOS to read configuration data) – NEMO

Opened 18 months ago

Closed 9 months ago

#2631 closed Task (wontfix)

Use XIOS to read configuration data

Reported by: andmirek Owned by: andmirek
Priority: low Milestone: 2021 WP
Component: IOM Version: trunk
Severity: minor Keywords:
Cc:

Description (last modified by andmirek)

Use XIOS to read configuration information from netcdf file. This work is continuation of the development started in ticet #2475

Workplan action

Wikipage: wiki:2021WP/HPC-09_Mirek_XIOS_configuration_data

Branch svn+ssh://andmirek@forge.ipsl.jussieu.fr/ipsl/forge/projets/nemo/svn/NEMO/branches/2021/dev_14544_xios_ancil

Commit History (2)

ChangesetAuthorTimeChangeLog
14559andmirek2021-03-01T14:37:10+01:00

Ticket #2631: first implementation (with debug prints)

14545andmirek2021-02-25T11:03:01+01:00

Ticket #2631 development branch

Change History (5)

comment:1 Changed 18 months ago by andmirek

  • Owner changed from systeam to andmirek
  • Status changed from new to assigned

comment:2 Changed 18 months ago by andmirek

In 14545:

Error: Failed to load processor CommitTicketReference
No macro or processor named 'CommitTicketReference' found

comment:3 Changed 18 months ago by andmirek

  • Description modified (diff)

comment:4 Changed 18 months ago by andmirek

In 14559:

Error: Failed to load processor CommitTicketReference
No macro or processor named 'CommitTicketReference' found

This version works with XIOS in detached mode only (for sette test ORCA2_ICE_PISCES) and number of servers must be less than 32 (tested with 4). It fails in context initialization for XIOS in attached mode and detached model with 32 XIOS servers with the error:

-> error : WARNING: Unexpected event of size 100 for server 31 (estimated max event size = 82)

I've sent question to XIOS team regarding this issue.

Last edited 18 months ago by andmirek (previous) (diff)

comment:5 Changed 9 months ago by andmirek

  • Resolution set to wontfix
  • Status changed from assigned to closed

An attempt to write a simple program to reproduce this issue failed. Because this development doesn't work in attached mode it will not be possible to test it in SETTE tests. This branch should be tested with new XIOS (v3) when it's released.

Note: See TracTickets for help on using tickets.