New URL for NEMO forge!   http://forge.nemo-ocean.eu

Since March 2022 along with NEMO 4.2 release, the code development moved to a self-hosted GitLab.
This present forge is now archived and remained online for history.
#2698 (Passive tracers not reproducible/restartable with AGRIF) – NEMO

#2698 closed Bug (fixed)

Passive tracers not reproducible/restartable with AGRIF

Reported by: jchanut Owned by: jchanut
Priority: normal Milestone: IMMERSE 2021
Component: AGRIF Version: trunk
Severity: minor Keywords:
Cc:

Description

Context

Restartability/Reproducibility? of passive tracers with AGRIF is broken in the trunk.
Although a passive tracer (Age) was used for years in AGRIF_DEMO, tracer.stat was not tested in Sette

Analysis

A few lines missing in the initialization part of passive tracers at boundaries in agrif_user.F90

Commit History (3)

ChangesetAuthorTimeChangeLog
15039jchanut2021-06-22T11:27:55+02:00

#2698, Repro/restart potential issue with AGRIF and passive tracers

15030jchanut2021-06-21T10:30:49+02:00

#2698, this restores restartability testing of Age passive tracer in AGRIF_DEMO. Added nn_hls=2 and other tests with AGRIF since there is no reason we do not succeed in making these work. Timing option is still missing with AGRIF though.

15029jchanut2021-06-21T09:21:01+02:00

#2698, fixes passive tracers repro/restart & remove euler time stepping in top namelists (not supported with AGRIF)

Change History (4)

comment:1 Changed 18 months ago by jchanut

In 15029:

Error: Failed to load processor CommitTicketReference
No macro or processor named 'CommitTicketReference' found

comment:2 Changed 18 months ago by jchanut

In 15030:

Error: Failed to load processor CommitTicketReference
No macro or processor named 'CommitTicketReference' found

comment:3 Changed 18 months ago by jchanut

In 15039:

Error: Failed to load processor CommitTicketReference
No macro or processor named 'CommitTicketReference' found

comment:4 Changed 18 months ago by jchanut

  • Resolution set to fixed
  • Status changed from new to closed

Added correction in r4.0-HEAD even if reproducibility and restartability of passive tracers are not tested in sette.

Note: See TracTickets for help on using tickets.