New URL for NEMO forge!   http://forge.nemo-ocean.eu

Since March 2022 along with NEMO 4.2 release, the code development moved to a self-hosted GitLab.
This present forge is now archived and remained online for history.
#2734 (Wrong vertical velocity at subdomain boundaries with ln_bt_fw = .false.) – NEMO

#2734 closed Bug (fixed)

Wrong vertical velocity at subdomain boundaries with ln_bt_fw = .false.

Reported by: gsamson Owned by: systeam
Priority: normal Milestone:
Component: DYN Version: trunk
Severity: minor Keywords:
Cc: clem, smasson, jchanut

Description

Context

Wrong vertical velocity at subdomain boundaries with ln_bt_fw = .false.


Analysis

There is an issue with vertical velocities when using ln_bt_fw = .False. in the trunk at the subdomain boundaries. Indeed, on the figure https://nemo-ocean.zulipchat.com/#narrow/stream/292415-validation-4.2E2.20RC/topic/wrong.20W.20at.20boundaries.20with.20ln_bt_fw.3Dfalse (daily average of the vertical velocity with AMM12 and ln_bt_fw = .False.) we can cleary distinguish the subdomain boundaries on W fields.

This issue is not present when ln_bt_fw = .true. . Note also that the problem is also not present in an older trunk revision (r14365) .

Fix

This feature is also distinguishable on the horizontal divergence hdiv so my guess is that it may be due to wrong scale factors or velocities in halos cells when using ln_bt_fw = .False.

Commit History (1)

ChangesetAuthorTimeChangeLog
15386jchanut2021-10-15T15:55:25+02:00

#2734: correct issue with ln_bt_fw=F introduced at r15061

Change History (2)

comment:1 Changed 14 months ago by jchanut

In 15386:

Error: Failed to load processor CommitTicketReference
No macro or processor named 'CommitTicketReference' found

comment:2 Changed 14 months ago by jchanut

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.