Opened 11 years ago

Closed 11 years ago

Last modified 3 years ago

#727 closed Bug (fixed)

wrong cpu ranking of iom_put files (coupled mode only)

Reported by: smasson Owned by: nemo
Priority: low Milestone:
Component: OCE Version: release-3.2
Severity: Keywords: 2010
Cc: Branch review:
MP ready?: Task progress:

Description

Error in cpu ranking of output files created by iom_put in coupled mode.
In coupled mode with the ioserver used in attached mode, the number of the cpu used to define the suffix of the file name is wrong (based on mpi_world instead of nemo local communicator).
Solution given and tested by A. Caubel: always specify ilocal_comm in the call of init_ioclient in opa.F90

Commit History (0)

(No commits)

Change History (9)

comment:1 Changed 11 years ago by smasson

  • Resolution set to fixed
  • Status changed from new to closed

done, see changeset:2170

comment:2 Changed 5 years ago by nicolasmartin

  • Keywords 2010 Coastal Stream ocean ready added

comment:3 Changed 5 years ago by nicolasmartin

  • Keywords nemo_v3_2* added

comment:4 Changed 5 years ago by nicolasmartin

  • Milestone 2010 Stream 0: Coastal ocean ready deleted

Milestone 2010 Stream 0: Coastal ocean ready deleted

comment:5 Changed 5 years ago by nicolasmartin

  • Keywords Stream ocean ready added; CSor removed

comment:6 Changed 5 years ago by nicolasmartin

  • Keywords Stream removed

comment:7 Changed 5 years ago by nicolasmartin

  • Keywords ocean removed

comment:8 Changed 5 years ago by nicolasmartin

  • Keywords ready removed

comment:9 Changed 3 years ago by nemo

  • Keywords nemo_v3_2* removed
Note: See TracTickets for help on using tickets.