New URL for NEMO forge!   http://forge.nemo-ocean.eu

Since March 2022 along with NEMO 4.2 release, the code development moved to a self-hosted GitLab.
This present forge is now archived and remained online for history.
user/gm/Namelist_framework (diff) – NEMO

Changes between Version 8 and Version 9 of user/gm/Namelist_framework


Ignore:
Timestamp:
2018-06-25T15:16:26+02:00 (4 years ago)
Author:
nicolasmartin
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • user/gm/Namelist_framework

    v8 v9  
    207207   - In logical namelist use "_OFF"  instead of "_NONE"   (e.g. ln_traldf_NONE ==> ln_traldf_OFF)   '''DONE in [changeset:9526 @9526]''' 
    208208   - "specific" namelist should be called '''self-contained''' or '''autonomous''' namelist 
     209 
     210From Nicolas: \\ 
     211''IMHO the best way to distinguish the different types of namelist should be from the name of the namelist itself. It would mean defining a naming convention like the ones we already have for files, modules and variables. \\ 
     212More or less it is what have been done so far with the naming of `namxxx` for manager namelist and `namxxx_xxxx` for related namelists, we should find a new naming convention to split related namelists between associate and specific namelists ''