Opened 7 years ago

Closed 7 years ago

#121 closed defect (fixed)

bug in calucaltion of evap_bare_lim_ns

Reported by: jgipsl Owned by: jgipsl
Priority: major Milestone:
Component: Anthropogenic processes Version:
Keywords: Cc:

Description

Aroung line 4475 in hydrol.f90 on the trunk rev 1850 following is found :

   !! 15.7 Determination of evap_bar_lim_ns
       DO ji = 1, kjpindex
          ! Here we weight evap_bare_lim_ns by the fraction of bare evaporating soil.
          ! This is given by frac_bare_ns, taking into account bare soil under vegetation
          IF(vegtot(ji) .GT. min_sechiba) THEN
             evap_bare_lim_ns(ji,:) = evap_bare_lim_ns(ji,:) * frac_bare_ns(ji,:)
          ELSE
             evap_bare_lim_ns(ji,:) = 0.
          ENDIF
       END DO

The problem is that this part is in a big loop jst=1,nstm (starting at line 4312) over soil tiles. But in the lines avove, the index for soil tile is treated all at onces (ji,:).

This should be rewritten using evap_bare_lim_ns(ji,jst).

Jan Polcher

Change History (1)

comment:1 Changed 7 years ago by jgipsl

  • Resolution set to fixed
  • Status changed from new to closed
  • Summary changed from bug in calucaltion of evap_bare_lim_nc to bug in calucaltion of evap_bare_lim_ns

Commit done on trunk rev [1852].
Change in results for CWRR.

Note: See TracTickets for help on using tickets.