Opened 6 years ago

Closed 6 years ago

#169 closed defect (fixed)

routing_main : pb in calculation order before restart

Reported by: jgipsl Owned by: jgipsl
Priority: major Milestone: IPSLCM6.v1
Component: Anthropogenic processes Version: trunc
Keywords: Cc:

Description

As corrected previously in condveg, the same problem is also found in routing_main, for condveg see ticket #145

The problem is the last call to routing_main. In this call only the writing to restart file should be done. But this is not the case because the restart section comes after the ordinary calculations.

In sechiba_main for the last time-step, each subroutine _main is called twice : first to do the calculations(ldrestart_write=false) and secondly to write to restart file(ldrestart_write=true). As a consequence, currently for routing_main, the calculations will be done twice at the last time-step.

Change History (2)

comment:1 Changed 6 years ago by jgipsl

Correction is done in commit [2580]. The section ldrestart_write is put higher up in routing_main after initialization section.

comment:2 Changed 6 years ago by jgipsl

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.