Opened 5 years ago

Closed 5 years ago

#193 closed enhancement (fixed)

sinang seems to have wrong name

Reported by: jgipsl Owned by: jgipsl
Priority: major Milestone: IPSLCM6.v1
Component: Anthropogenic processes Version: trunc
Keywords: Cc:

Description (last modified by lathiere)

The name of the variable sinang is misleading and the corresponding comments seems to be wrong.

sinang is calculated in the subroutine solarang in offline mode. According to this subroutine it is the cosine of zenith solar angle which is calculated. Using LMDZ it is the cosinus of the zenith angle which is provided. This also corresponds to the sinus of the elevation angle, which is the complementary angle of the zenith solar angle (which is probably why "sinang" was chosen in the first place, but bringing confusion).

Proposition:
If it is confirmed that the sinang is in fact the cosinus of the zenith solar angle, which has to be used, then the variable sinang in ORCHIDEE should change name into coszang.

Change History (4)

comment:1 Changed 5 years ago by jgipsl

  • Owner changed from somebody to jgipsl
  • Status changed from new to accepted

comment:2 Changed 5 years ago by lathiere

  • Description modified (diff)

comment:3 Changed 5 years ago by jgipsl

  • Changed name in trunk orchidee source code : [2961]
  • Removed Sinang in configuration
  • coszang is not added in the PARAM/file_def_orchidee.xml in the configurations yet. But it is added in src_xml/file_def_orchidee.xml. I hesitate to add it also in PARAM/file_def_orchidee.xml because it complicates if someone uses an older version of the sources with latest version of configuration.

comment:4 Changed 5 years ago by jgipsl

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.