Opened 6 years ago

Closed 5 years ago

#281 closed enhancement (fixed)

cap on lai

Reported by: luyssaert Owned by: luyssaert
Priority: major Milestone: IPSLCM6.v2
Component: Physical processes Version:
Keywords: Cc:

Description

in the first time step lai is prescribed (8, 4, ...), lai is not capped in ORCHIDEE-CAN so this should be checked and probably removed.

Change History (8)

comment:1 Changed 6 years ago by aresovsky

  • Owner changed from somebody to aresovsky
  • Status changed from new to accepted

comment:2 Changed 6 years ago by aresovsky

  • Resolution set to fixed
  • Status changed from accepted to closed

It appears lai_max is currently not being used to cap LAI anywhere in the code. In stomate_growth_fun_all, it is being used to derive lai_happy (lai_happy(:) = lai_max(:) * lai_max_to_happy(:)), but this parameter only sets the lower bound for whether carbohydrate reserves should be used in allocation. Ticket closed.

comment:3 Changed 6 years ago by luyssaert

  • Resolution fixed deleted
  • Status changed from closed to reopened

(1) It should be checked how the model deals with LAI prior to stomate_prescribe. Ideally there should be no LAI in the deciduous trees and crops. In a previous version some LAI was noticed on the first day. These values were rather high. It is not clear where these values come from.
(2) Several functions pass lai around. By doing so it is not clear which lai is passed around. To be sure that the latest value is used, biomass should be passed around and lai should be calculated (with the function biomass_to_lai) whenever needed.

comment:4 Changed 6 years ago by aresovsky

  • Resolution set to fixed
  • Status changed from reopened to closed

Calculation of LAI is now consistent throughout stomate. Changed sechiba.f90 and diffuco.f90 so LAI is now calculated using biomass_to_lai at the beginning of those routines as well before calling other subroutines.

comment:5 Changed 6 years ago by luyssaert

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:6 Changed 6 years ago by luyssaert

  • Owner changed from aresovsky to luyssaert
  • Status changed from reopened to assigned

comment:7 Changed 6 years ago by luyssaert

Following the merge of ORCHIDEE-CN-CAN with the trunk, LAI doubled between r4132 (stable CN-CAN or DESIRE light version) and r4372 (ORCHIDEE-CN-CAN including all AR6 changes). Two bugs had to be fixed: (1) r4372 was not using the k_latosa_xxx values from the run.def and (2) a hack (bypassing Pgap) that was required to do the merge was not yet removed resulting in a wrong lstress_fac which in turn is used to calculate KF. Revision r4393 was able to closely reproduce the LAI dynamics of r4132 over 50 years for all the evergreen PFTs.

Things to do concerning LAI:

(1) Deciduous PFTs in revision r4393 grow much slower than in r4132. In between these two versions the way the reserves are calculated has been revised. Needs to be checked whether we want to keep all of these revisions or adjust the parameters.
-> No obviuous problems were found in the code changes inhereted from ORCHIDEE-CN. Given that those changes were younger than the code r4372 they were retained. The values for k_latosa were manually tuned.

(2) C4 grasslands slowly dies in both r4231 and r4393.
-> This problem was fixed by slightly increasing k_latosa for C4 grasslands.

(3) C3 and C4 crops have an unrealisticaly high LAI.
TO DO: run the model with the r4372 code for the reserves and check whether this is the cause. If not search for the cause before changing the parameters.

(4) Check whether LAI is recalculated from biomass rather than being passed around as an argument.
TO DO: still need to check this

Last edited 6 years ago by luyssaert (previous) (diff)

comment:8 Changed 5 years ago by aresovsky

  • Resolution set to fixed
  • Status changed from assigned to closed

(1): OK
(2): OK
(3): Adjust K_LATOSA_MIN and K_LATOSA_MAX in run.def from 0.1 to 0.4 for crops to achieve realistic LAI values
(4): LAI is recalculated from biomass wherever it is needed in the code. This was fixed in r4492.

Note: See TracTickets for help on using tickets.