Opened 5 years ago

Closed 4 years ago

#332 closed defect (fixed)

Negative mineralization values in nitrogen_dynamics

Reported by: aresovsky Owned by: luyssaert
Priority: major Milestone: IPSLCM6.v2
Component: Biogeochemical processes Version:
Keywords: litter, biomass, mineralisation, hack Cc:

Description

n_mineralisation values entering nitrogen_dynamics are sometimes negative when using IMPOSE_CN=n. It is not clear where these come from, but they may be related to a bug in stomate_litter (negative litter values?). The ultimate problem may be negative biomass on the first day when using IMPOSE_CN=n. These negative N mineralization values are patched using a hack for now.

Change History (7)

comment:1 Changed 4 years ago by luyssaert

  • Milestone set to IPSLCM6.v2

comment:2 Changed 4 years ago by aresovsky

It was decided by the CN-CAN team that n_mineralisation values can be permitted to enter nitrogen_dynamics, where they may be treated as N immobilsation. However, the amount of negative n_mineralisation (immobilisation) allowed is limited by the amount of available N in the soil (soil_n_min). See changesets 4114 and 4121.

comment:3 Changed 4 years ago by luyssaert

In stomate_litter.f90 and in som_dynamics (a subroutine of stomate_soilcarbon.f90), the newly calculated n_mineralization is compared against the soil nitrogen that can be immobilised. If there is enough nitrogen to immobilse the negative mineralisation, the estimated n_mineralisation is kept. If the nitrogen demand of the negative n_mineralisation cannot be satisfied, n_mineralisation and all subsequant pools and fluxes are recalculated such that they use all the available soil nitrogen for immobilisation.

Changes were committed in r4505

Last edited 4 years ago by luyssaert (previous) (diff)

comment:4 Changed 4 years ago by luyssaert

  • Resolution set to fixed
  • Status changed from new to closed

comment:5 Changed 4 years ago by luyssaert

  • Resolution fixed deleted
  • Status changed from closed to reopened

While running the model at 10 different pixels, 5 runs crashed either with negative litter or negative mineralization.

Negative liter

/home/satellites8/jjeong/CN.CAN/config/ORCHIDEE_OL/sites.100yr8
after 315 yr
/home/satellites8/jjeong/CN.CAN/config/ORCHIDEE_OL/sites.100yr6
after 139 yr

Negative soil N

Value given in out_orchidee-file:
/home/satellites8/jjeong/CN.CAN/config/ORCHIDEE_OL/sites.100yr7
after 20 yr
Mass balance error after taking N from atmosphere :
/home/satellites8/jjeong/CN.CAN/config/ORCHIDEE_OL/sites.100yr8
after 38 yr
Mass balance error after taking N from atmosphere :
/home/satellites8/jjeong/CN.CAN/config/ORCHIDEE_OL/sites.100yr9
after 272 yrOne set-up that crashed on negative litter can be found at /home/satellites8/jjeong/CN.CAN/config/ORCHIDEE_OL/sites.100yr.new/

The litter crash seems to be real because litter has a value of -10e-5. The soil_n_min problem seems to be a precision/initialisation problem because the value is -10e-61. Different crashes caused by negative values for soil_n_min give different error messages indicating that the there could be more than one problem which is caused at different places in the code.

comment:6 Changed 4 years ago by luyssaert

  • Owner changed from somebody to luyssaert
  • Status changed from reopened to assigned

comment:7 Changed 4 years ago by luyssaert

  • Resolution set to fixed
  • Status changed from assigned to closed

Revision r4574 fixed all the above problems. Following svn update all simulations were completed without any issues.

Note: See TracTickets for help on using tickets.