Opened 6 years ago

Closed 6 years ago

#392 closed defect (fixed)

Change variable name veget_max in stomate_lpj

Reported by: jgipsl Owned by: jgipsl
Priority: major Milestone: ORCHIDEE 2.0
Component: Anthropogenic processes Version: trunc
Keywords: Cc:


Currently in stomatelpj suboroutine, the intent(in) variable veget_max has a very confusing name. This veget_max is not the same as the veget_max in sechiba or in stomate_main. In stomate_main this variable corresponds to veget_cov_max. It is the same for veget_max_new which corresponds to veget_cov_max_new in stomate_main.

To be done:
Change names in stomateLpj of variables

  • veget_max into veget_cov_max
  • veget_max_new into veget_cov_max_new

Change name for veget_max and veget_max_new also in the underlaying subroutines called from stomateLpj:

  • crown
  • prescribe
  • pftinout
  • kill
  • phenology
  • alloc
  • fire
  • turn
  • light
  • establish
  • cover
  • harvest
  • lcchange_main

Change History (3)

comment:1 Changed 6 years ago by jgipsl

  • Resolution set to fixed
  • Status changed from new to closed

Done in the trunk rev [4647].
Note that veget_cov_max is not used in the following subroutines but it is still passed as argument: phenology, crown, fire, turn, maint_respiration. Nothing will be done about this now.

comment:2 Changed 6 years ago by jgipsl

  • Resolution fixed deleted
  • Status changed from closed to reopened

[4821] : Adapted stomate.card and monitoring to use VEGET_COV_MAX instead of old VEGET_MAX not existing anymore.

To be done : this needs to be done in the coupled model too.

comment:3 Changed 6 years ago by jgipsl

  • Resolution set to fixed
  • Status changed from reopened to closed

Adaptation of stomate.card and monitoring was already done in the coupled configurations, see changeset here :

Note: See TracTickets for help on using tickets.