Opened 2 years ago

Closed 4 days ago

#453 closed enhancement (fixed)

Add NBP to stomate_history files

Reported by: luyssaert Owned by: luyssaert
Priority: minor Milestone: ORCHIDEE 4.1
Component: Biogeochemical processes Version: trunc
Keywords: Cc:

Description

In CAN variables that could calculated from other variables were no longer written to the history files and were calculated during post-processing. Nevertheless, it would be convenient to add the flux-based and the pool-based calculation of NBP back into ORCHIDEE-CN-CAN to two approaches to more easily evaluate the spin-up.

Change History (9)

comment:1 Changed 2 years ago by luyssaert

A flux-based, pool-based and consistency cross-check of NBP were added as part of ticket #744. More details are provided in the description of that ticket. Following commits contributed to ticket #744 and this ticket (#753). r6977, r6982, r6982, r6988, r6989, and r7011.

Once NBP has been implemented, the new functionality could be used to run two spin-ups: (1) PFT map as an initial state file (veget_update = 0Y) and (2) the same PFT map is read as a boundary file with veget_update = 1Y.

This was tested with r7089 and this revision still passed the test after 11 years with the SPINUP_ANALYTIC_FG1.

Before we could run this some other issues were found. Following Vlad, the model was started with a PFT map read as an initial state file and alternatively with the same PFT file but read as a boundary file that is refreshed every year. The model was run for just 20 years with daily output.

On January 22nd of the first year, differences started to occur in allocation of 10E-15 to 10E-18 gC tree-1. Twenty years later those difference had propagated through most of the stomate variables. The differences were still small but became noticeable.

This problem could not be reproduced for r7089 after 11 years with the SPINUP_ANALYTIC_FG1. The variable tested was NBP_flux_c which integrates several of the C fluxes calculated in stomate.

We think that:
(1) The magnitude of the difference hint at a precision issue. It remains unclear why the first difference is seen on January 22nd and not on January 1st. Could it take 22 days before the difference is large enough to be detected by cdo diffv?

One of the problems solved for ticket #744 was a precision issue related to the litter decomposition.

(2) The observation that the differences started well before the land cover change module is used is interesting. Something seems to be going wrong well before land cover change (which of course does not mean that later on nothing is going wrong in land cover change as well).

land cover change now occurs on the first day of the year. This comment seems no longer valid.

(3) The stomate modules that are called at the end of every day do not depend on the land cover change flag. We interpreted this as a hint that the code used to read an Initial state file slightly differs from the code reading a boundary file.

Note that since r6616 slowproc.f90 where some of the maps are read, has changed substantially. Because r6616 and later check for mass conservation, reading of the LCC map (and especially rounding veget_max) was rewritten to ensure surface area preservation (which is a prerequisite for mass conservation). Some of these changes could have contributed to solving this issue.

Last edited 4 days ago by luyssaert (previous) (diff)

comment:2 Changed 2 years ago by alanso

  • Owner changed from somebody to alanso
  • Status changed from new to assigned

comment:3 Changed 2 years ago by luyssaert

r5597 can calculate NBP during the spin-up

comment:4 Changed 13 months ago by luyssaert

  • Priority changed from major to minor

comment:5 Changed 12 months ago by luyssaert

  • Milestone changed from IPSLCM6.v2 to ORCHIDEE 4.0
  • Owner changed from alanso to somebody

comment:6 Changed 11 months ago by luyssaert

  • Milestone changed from ORCHIDEE 4.0 to Not scheduled yet
  • Version set to trunc

comment:7 Changed 5 days ago by luyssaert

  • Milestone changed from Not scheduled yet to ORCHIDEE 4.1

comment:8 Changed 4 days ago by luyssaert

  • Owner changed from somebody to luyssaert

comment:9 Changed 4 days ago by luyssaert

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.