Opened 2 years ago

Closed 2 years ago

#486 closed defect (fixed)

Excessive warnings about nitrogen

Reported by: mmcgrath Owned by: somebody
Priority: minor Milestone: IPSLCM6.v2
Component: Physical processes Version:
Keywords: Cc:

Description

Using r5693 of ORCHIDEE-CN-CAN and r5693 of config/ORCHIDEE_OL/OOL_SEC_STO_FG1trans for the CN-CAN ORCHIDEE_OL (no change in run.def), I have a series of the following warnings on obelix using a single processor:

WARNING: ivm,icarbon,initrogen,ipts 36 1 2

1

WARNING: som_input_new(ivm,initrogen), n_min_old(ipts,ivm)

0.000000000000000E+000 0.000000000000000E+000

WARNING: n_min_new(ipts,ivm),n_mineralisation(ipts,ivm),som_input_new(ivm,icarb
on) -9.255963134931783E+061 -3.360425884691281E-003 1.421307281903881E-002

WARNING FROM ROUTINE stomate_litter

--> Perhaps no n_mineralization pools, but new litter
--> Previously only seen in cases where GPP is zero for long term
-->

After discussing with Sebastiaan, these warnings are to be expected for certain PFTs. We are going to look into changing it so that warnings are only produced when they signal actually warnings (not things that are expected). Unclear if this is possible for initial runs.

"It is caused by a “forest bias”. If the warning is seen for a forest/grassland it should be considered a real warning. If it is seen for a cropland outside the growing season it is to be expected (so not really a warning). Adding an IF(is_tree) would probably restore the usefulness of this warning."

Change History (1)

comment:1 Changed 2 years ago by luyssaert

  • Resolution set to fixed
  • Status changed from new to closed

IF (is_tree) was added during the merge.

Note: See TracTickets for help on using tickets.