Opened 3 years ago

Closed 2 years ago

#583 closed defect (fixed)

Low GPP for MTC10,11 and 12

Reported by: luyssaert Owned by: luyssaert
Priority: critical Milestone: IPSLCM6.v2
Component: Biogeochemical processes Version:
Keywords: Cc:

Description

The current parameter values result in a too low GPP for MTC12 in North America and Europe. The GPP is especially low in the core cropping areas (400 gC m-2 y-1) and increases to 1050 gC m-2 y-1 towards the more northern edges of the cropping areas. This could hint at excessive water stress. Increasing K_LATOSA did not result in a higher GPP for MTC12 but it did help to get an acceptable GPP for MTC13.

Change History (11)

comment:1 Changed 3 years ago by jgipsl

  • Priority changed from major to critical

comment:2 Changed 3 years ago by luyssaert

Last edited 3 years ago by luyssaert (previous) (diff)

comment:3 Changed 3 years ago by luyssaert

r6432 was run without water stress (FM1, unstressed) and with the water stress switched on for FM1 and FM2.

Name #PFT GPP FM1, unstressed GPP FM1, stressed GPP FM2, stressed NPP/GPP July LAI Comment
BroadLeavedEvergreenTropical 2 - - - - - -
BroadLeavedRaingreenTropical 3 - - - - - -
NeedleleafEvergreenTemperate 4 1200 1000 800 0.5 - Check RDI
BroadLeavedEvergreenTemperate 5 1200 1200 1000 0.5 - OK
BroadLeavedSummergreenTemperate 6 1200 1200 1200 0.5 - OK
NeedleleafEvergreenBoreal 7 600 600 300 0.5 - Check RDI
BroadLeavedSummergreenBoreal 8 1000 1000 700 0.5 - OK
LarixSpBoreal 9 1100 1100 1100 0.5 - In the Alps
!C3GrassTemperate 10 800 300 300 0.6 ~3.5 Check GPP & water stress
!C4GrassTemperate 11 - - - - - -
!C3AgricultureTemperate 12 800 300 300 0.6 ~2.0 Check GPP & water stress
!C4AgricultureTemperate 13 1000 300 300 0.6 ~2.2 Check GPP & water stress
!C3GrassTropical 14 - - - - - -
!C3GrassBoreal 15 700 300 300 0.6 ~2.0 Check GPP & water stress

Overall the GPP is on the low side but it could be for different reasons for different PFTs.

Last edited 2 years ago by luyssaert (previous) (diff)

comment:4 Changed 2 years ago by luyssaert

In r6432 PFT 12 and 13 are still growing. In r6444 PFT12 and 13 are no longer growing.

In r6444 the short vegetation (PFT10-15) hardly grows after 12 years and even the first years the vegetation dies over the course of three years. The first year the LAI, its phenology and plant_status all look OK. The second year, plant_status seems to work properly but the initial LAI is very low. There is still some labile and reserve N left but less than the first year. The same pattern was already present in r6432. This may have been the cause of the low overall GPP and LAI.

For PFT10 the LABILE_M_c+RESERVE_M_c is low at the end of the first year, the LABILE_M_n+RESERVE_M_n is higher at the end than at the beginning of the year, hence the N dynamics are unlikley to be the first order cause of the problem.



Last edited 2 years ago by luyssaert (previous) (diff)

comment:5 Changed 2 years ago by luyssaert

  • Owner changed from somebody to luyssaert
  • Status changed from new to assigned

comment:6 Changed 2 years ago by luyssaert

  • Owner changed from luyssaert to jjeong

comment:7 Changed 2 years ago by luyssaert

  • Owner changed from jjeong to luyssaert

comment:8 Changed 2 years ago by luyssaert

Compared PFT10 against PFT6. The following observations were made:

  • In PFT6 the LAI develops quickly towards max LAI during spring. In PFT10 the max LAI is reached in september. This issue has been fixed for the trees in r6016. This contributes to differences in the reserves and labile pools.

-> Similar to the tree PFTs, grass and crops PFTs now pre-calculate the allocatable carbon based on the plant available nitrogen. This improves the allocation considerable. See r6462.

  • Root conductivity has been increased for trees (incl. PFT6). This resulted in a low root mass (~10 g m-2) and thus makes growing a full canopy easier. In PFT10 roots and canopy are of the same magnitude. This is not the problem the first year and does not explain the difficulties to grow a canopy the second year.

-> See ticket #654 which needs to be fixed first!

  • At the start of phenology almost all reserves and labile are invested in the roots in PFT10. Almost no carbon goes into the canopy (10e-4). PFT6 and PFT10 use a different approach of calculating the initial leaf mass. This could contribute to the problem.

-> fixed in r6460

  • Plant n uptake depends on iroot + isapbelow but for grasses isapbelow is zero. So plant uptake is zero in winter because iroot is zero in winter. This does not explain the difficulties to grow a canopy the second year because there seems to be sufficient N in the labile and reserve pools.

-> fixed in r6459

  • Lab_fac of trees and grasses was very different in the sense that lab_fac is above 0.3 for large part of the growing season in grasses (affecting some other calculations). For trees lab_fac is rarely above 0.3 and thus hardly has any impact.

-> in r6462 lab_fac was fixed to 0.1 for grasses and crops. A cleaner solution would be to remove lab_fac. See ticket #655.

Last edited 2 years ago by luyssaert (previous) (diff)

comment:9 Changed 2 years ago by luyssaert

  • Summary changed from Low GPP for MTC12 to Low GPP for MTC10 and 11

comment:10 Changed 2 years ago by gmarie

  • Summary changed from Low GPP for MTC10 and 11 to Low GPP for MTC10,11 and 12

comment:11 Changed 2 years ago by luyssaert

  • Resolution set to fixed
  • Status changed from assigned to closed

Running r6470 with the FG2 over Europe and Africa does no longer contains any hints of too low GPP. GPPs seems to be very reasonable given their LAI (which are also reasonable).

Note: See TracTickets for help on using tickets.