#626 closed defect (fixed)

Negative metabolic litter pools

Reported by: luyssaert Owned by: luyssaert
Priority: blocker Milestone: IPSLCM6.v2
Component: Biogeochemical processes Version:
Keywords: Cc:

Description

When running r6332 with LCC the model crashes with the following message

21FATAL ERROR FROM ROUTINE stomate_litter
21 --> Negative metabolic litter pools
21 --> This should not be the case
21 -->

Change History (3)

comment:1 Changed 13 months ago by jgipsl

While running SPINUP_ANALYTIC (VEGET_UPDATE=0) with revision 6324, I got following error messages on the 11'th year of simulation (10year cycle) :

4FATAL ERROR FROM ROUTINE stomate_litter
4 --> Negative woody litter pools
4 --> This should not be the case

or

21FATAL ERROR FROM ROUTINE stomate_litter
21 --> Negative litter pools
21 --> This should not be the case

But first, in the second year, the model crash on the output variable SOIL_P_OX which becomes Nan, so I have to remove this diag or set prec=8 in field_def_orchidee.xml to come as far as the 11th year.

Last edited 13 months ago by jgipsl (previous) (diff)

comment:2 Changed 13 months ago by luyssaert

Negative metabolic litter pools were caused by a precision error in the recalculation of litter in cases where there is not enough N to decompose all the available litter. The influx from litter to the soil needs to be reduced. This fix has been committed in r6348.

A global FG1 simulation was run for 100 years with 15 pfts and 1 age class. All reported problems with negative litter pools seem to have been resolved.

Last edited 13 months ago by luyssaert (previous) (diff)

comment:3 Changed 13 months ago by luyssaert

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.