Opened 12 months ago

Closed 12 months ago

Last modified 12 months ago

#630 closed defect (fixed)

rh is not equal to rhsoil+rhlitter

Reported by: bguenet Owned by: bguenet
Priority: major Milestone: ORCHIDEE 3.0
Component: Biogeochemical processes Version: trunc
Keywords: Cc:

Description

In orchidee the heterotrophic respiration has 2 components the one coming from litter decomposition and the one coming from soil decomposition. The problem is that when looking at the sum of rhSoil and rhLit this is not equal to rh.

There is three corrections that must be done.

  1. In src_xml/file_def_orchidee.xml

The lines
<field id="rhSoil" name="rhSoil" long_name="Carbon mass flux due to heterotrophic respiration from soil on land (positive from land to atm)" unit="kg C m-2 s-1" > this*(-1) </field>

<field id="rhLitter" name="rhLitter" long_name="Carbon mass flux due to heterotrophic respiration from litter on land (positive from land to atm)" unit="kg C m-2 s-1" > this*(-1) </field>

should be modified as following:
<field id="rhSoil" name="rhSoil" long_name="Carbon mass flux due to heterotrophic respiration from soil on land (positive from land to atm)" unit="kg C m-2 s-1" />

<field id="rhLitter" name="rhLitter" long_name="Carbon mass flux due to heterotrophic respiration from litter on land (positive from land to atm)" unit="kg C m-2 s-1" />

  1. rhLit and rhSoil must be corrected by one_day changing

CALL xios_orchidee_send_field("rhSoil",SUM(resp_hetero_soil*veget_cov_max,dim=2)/1e3)
CALL xios_orchidee_send_field("rhLitter",SUM(resp_hetero_litter*veget_cov_max,dim=2)/1e3)

into

CALL xios_orchidee_send_field("rhSoil",SUM(resp_hetero_soil*veget_cov_max,dim=2)/1e3/one_day)
CALL xios_orchidee_send_field("rhLitter",SUM(resp_hetero_litter*veget_cov_max,dim=2)/1e3/one_day)

  1. This calculation must be done in stomate_lpj and not in stomate to take into account LUC

Change History (3)

comment:1 Changed 12 months ago by jgipsl

Correction done in the trunk [6362]

comment:2 Changed 12 months ago by bguenet

  • Resolution set to fixed
  • Status changed from new to closed

comment:3 Changed 12 months ago by jgipsl

Same correction done in the tag 2.0 in changeset [6367] and [6368].

Same correction done in the branch 2.2 in changeset [6369].

Note: See TracTickets for help on using tickets.