Opened 9 months ago

Closed 8 months ago

#645 closed defect (fixed)

crash in xios when running in debug mode

Reported by: luyssaert Owned by: luyssaert
Priority: major Milestone: IPSLCM6.v2
Component: Physical processes Version:
Keywords: Cc:

Description

When compiling r6434 in debug mode the model crashes when trying to write rveget. The problem can be circumvented by setting

field_definition prec="4"

to

field_definition prec="8"

Change History (6)

comment:1 Changed 9 months ago by luyssaert

Initialized rveget and used the opportunity to do some cleaning of variable initialization but these changes did not fix the problem. If the problem happens where the model crashes, xios has difficulties with writing 0.00000000000e+000.

comment:2 Changed 9 months ago by jjeong

  • Owner changed from somebody to jjeong
  • Status changed from new to assigned

comment:3 Changed 9 months ago by jjeong

  • Resolution set to fixed
  • Status changed from assigned to closed

Tested with 1pixel, and 4pixels for 1 processor and 3 processors. The problem was not reproduced.

comment:4 Changed 9 months ago by luyssaert

  • Resolution fixed deleted
  • Status changed from closed to reopened

The model crashed with the same problem a couple of years later than previously.

comment:5 Changed 9 months ago by luyssaert

  • Owner changed from jjeong to luyssaert
  • Status changed from reopened to assigned

comment:6 Changed 8 months ago by luyssaert

  • Resolution set to fixed
  • Status changed from assigned to closed

The crash could no longer be reproduced with r6460 (same test case as before). It is not clear what made it disappear.

Note: See TracTickets for help on using tickets.